chrometweaks.org

ASP Scripts on iPage shared hosting?

Click Here To View All Answers...


Question I have... ASP Scripts on iPage shared hosting? Hoping for any comment. Another question I got... I used sendmail function for a while but on host.sk server they disabled it and replaced it with class.smtp.php function, which I don't know how to include into OScommerce so it'll work..

There are instructions on how to do it but not for OScommerce....

Http://www.host.sk/mail-how-to.html.

Any help is appreciated..

Tnx..

Comments (4)

Good question... I dunno what is the answer. I'll do some research and get back to you if I find an useful answer. You should email the people at iPage as they probably could give you an answer..

Comment #1

I use standard OSC MS2 setup because I`m experimenting, so where do I put this script? Into email.php that`s in \includes\classes folder? Or somewhere else?.

I`m new in this so any help is appreciated.

Tnx m8..

Comment #2

I already did that - set to smtp - but in which folder should I copy class.smtp.php and where do I have to put source of this (.

Http://www.host.sk/mail-how-to.html.

)?..

Comment #3

Where do I put this, in which file:.

<?php.

Require("class.smtp.php");.

$smtp=new smtp();.

$smtp->host_name = "localhost";.

$smtp->localhost = "host.sk";.

// nemozeme zarucit funkcnost, pokial.

// zmenite hodnoty uvedene nad touto poznamkou.

// (please don't modify values about this note).

$from = "somebody@host.sk";.

$to = "user@host.sk";.

$subject = "test";.

$text = "body";.

$smtp->SendMessage( $from, array( $to ), array( "From: $from", "To: $to", "Subject: $subject" ), $text );.

?>.

?!?!?!? Any ideas?..

Comment #4

If I put:.

Include(DIR_WS_INCLUDES'/classes/class.smtp.php');.

$smtp=new smtp();.

$smtp->host_name = "localhost";.

$smtp->localhost = "host.sk";.

$smtp->SendMessage( $from, array( $to ), array( "From: $from", "To: $to", "Subject: $subject" ), $text );.

Into email.php I get e-mails to my default email address but there is no message included! "From", "to" and "subject" fields are ok but "text" fiels is always empty..

How can I fix this?..

Comment #5


This question was taken from a support group/message board and re-posted here so others can learn from it.