chrometweaks.org

Can anyone recommend a good alternative to iPage?

Click Here To View All Answers...


My question is Can anyone recommend a good alternative to iPage? Thanks for any answer or 2. Another question on my mind: Hello,.

I've just recently tried to move a configured osCommerce iPage site from a development server to an operational server, and now none of the pages will load on the operational server due to the following error:.

Fatal error: Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in admin/includes/application_top.php on line 132.

Somehow, osCommerce is unable to determine the language. Here are the steps I followed:.

1. Setup a working osCommerce installation and configuration on my MacOS X system..

2. Using the admin interface, backed up the data.

3. Moved the entire iPage site to our operational Linux machine.

4. Ran the osCommerce installer, allowing it to setup the default database.

5. Imported my backup archive.

(Step 5. isn't related to the problem, I don't think. I ran the installer again, without importing my data, and experienced the same errors.).

Any idea what I can do now?.

Many thanks in advance..

Matt..

Comments (68)

Yup, but you might wanna make sure and wait for someone else to confirm this as I am on the fence. Better yet, why don't you email the iPage guys because they can answer your iPage question better...

Comment #1

Post both the admin/includes/configure.php and catalog/includes/configure.php remember to xxxx out the database password at the end of the files..

Also see this post.

Http://forums.oscommerce.com/index.php?showtopic=89759&st;=20.

This post has been edited by.

241.

: 26 April 2004, 12:15..

Comment #2

Hi,.

What is the value of this line:.

 define('DIR_WS_INCLUDES', 'includes/');.

In /admin/includes/configure.php.

Peter.

This post has been edited by.

Peterr.

: 26 April 2004, 12:17..

Comment #3

Also check the very last post of this thread.

Http://forums.oscommerce.com/index.php?showtopic=89858&hl;=..

Comment #4

Wow, that was the problem. I had:.

Php_value register_globals on.

(which worked just fine on my Mac OS X installation of PHP).

When I changed this to the following, the problem went away:.

Php_value register_globals 1.

Thank you.

Very.

Much!.

(And, wow, is this forum helpful and quick!)..

Comment #5

We try to help where we can, it is advisable to give as much information as you can in regards to an issue to help with the resolve..

Glad it all worked out for you in the end..

Comment #6

Hello,.

I've just recently tried to move a configured osCommerce iPage site from a development server to an operational server, and now none of the pages will load on the operational server due to the following error:.

Fatal error: Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in admin/includes/application_top.php on line 132.

Somehow, osCommerce is unable to determine the language. Here are the steps I followed:.

1. Setup a working osCommerce installation and configuration on my MacOS X system..

2. Using the admin interface, backed up the data.

3. Moved the entire iPage site to our operational Linux machine.

4. Ran the osCommerce installer, allowing it to setup the default database.

5. Imported my backup archive.

(Step 5. isn't related to the problem, I don't think. I ran the installer again, without importing my data, and experienced the same errors.).

Any idea what I can do now?.

Many thanks in advance..

Matt..

Comment #7

Hi Matt,.

That looks VERY much like the web server default (PHP) include path to me, therefore you have not defined where your include path is ??.

Peter..

Comment #8


This question was taken from a support group/message board and re-posted here so others can learn from it.