chrometweaks.org

Does same company provides both internet service connection and web iPage hosting services?

Click Here To View All Answers...


First off, Does same company provides both internet service connection and web iPage hosting services? Thanks for any answer or 2. Another question... I've done a search and I can't seem to find a thread that helps me. I'm sure it's something silly and simple, but I can't get it working..

The iPage site was working fine locally. The database worked, orders showed in admin, etc. I installed the GV contribution and it still worked fine. I uploaded the iPage site to the root rather than to a catalog folder and made the changes to the configure files (i think.

). I'm guessing this must be where the problem is. The orders show in the database if I look at phpMyAdmin, but they are not showing in the Orders section. The customer gets the confirmation email, etc. The Gift Vouchers also do not show (I'm figuring they are related to the same problem.) My only guess is that there is something wrong with the configure files. I tried to do them exactly as the old ones on the iPage site had been, just taking out the catalog part, but obviously I did something wrong.

Here are the configure files:.

Admin:.

//Define the webserver and path parameters.

// * DIR_FS_* = Filesystem directories (local/physical).

// * DIR_WS_* = Webserver directories (virtual/URL).

 define('HTTP_SERVER', 'http://www.pattibears.com'); // eg, http://localhost - should not be empty for productive servers.

 define('HTTP_CATALOG_SERVER', 'http://www.pattibears.com');.

 define('HTTPS_CATALOG_SERVER', '');.

 define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module.

 define('DIR_FS_DOCUMENT_ROOT', '/home/pattibea/public_html/'); // where the pages are located on the server.

 define('DIR_WS_ADMIN', '/admin/'); // absolute path required.

 define('DIR_FS_ADMIN', '/home/pattibea/public_html/admin/'); // absolute pate required.

 define('DIR_WS_CATALOG', '/'); // absolute path required.

 define('DIR_FS_CATALOG', '/home/pattibea/public_html/'); // absolute path required.

 define('DIR_WS_IMAGES', 'images/');.

 define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG'images/');.

 define('DIR_WS_INCLUDES', 'includes/');.

 define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

 define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

 define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG'includes/languages/');.

 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG'includes/languages/');.

 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG'images/');.

 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG'includes/modules/');.

 define('DIR_FS_BACKUP', DIR_FS_ADMIN'backups/');.

// define our database connection.

 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers.

 define('DB_SERVER_USERNAME', xxxxx);.

 define('DB_SERVER_PASSWORD', 'xxxxx');.

 define('DB_DATABASE', 'xxxxx');.

 define('USE_PCONNECT', 'false'); // use persisstent connections?.

 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'.

?>.

And the catalog one:.

// Define the webserver and path parameters.

// * DIR_FS_* = Filesystem directories (local/physical).

// * DIR_WS_* = Webserver directories (virtual/URL).

 define('HTTP_SERVER', 'http://www.pattibears.com'); // eg, http://localhost - should not be empty for productive servers.

 define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers.

 define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

 define('HTTP_COOKIE_DOMAIN', 'www.pattibears.com');.

 define('HTTPS_COOKIE_DOMAIN', '');.

 define('HTTP_COOKIE_PATH', '/');.

 define('HTTPS_COOKIE_PATH', '');.

 define('DIR_WS_HTTP_CATALOG', '/');.

 define('DIR_WS_HTTPS_CATALOG', '');.

 define('DIR_WS_IMAGES', 'images/');.

 define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

 define('DIR_WS_INCLUDES', 'includes/');.

 define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

 define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

 define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

 define('DIR_FS_CATALOG', '/home/pattibea/public_html/');.

 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

// define our database connection.

 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers.

 define('DB_SERVER_USERNAME', xxxxx);.

 define('DB_SERVER_PASSWORD', 'xxxxx');.

 define('DB_DATABASE', xxxxx);.

 define('USE_PCONNECT', 'false'); // use persistent connections?.

 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'.

?>.

I apologize in advance if it is something really dumb...i just can't see it, whatever it is! If you have any other suggestions of files I should look at, let me know! I thought the only files that needed to be changed were the configure files when you moved it to the root, but maybe i'm missing something..

Thanks!..

Comments (297)

The answer is Yes, however you might want to make sure and wait for another member here to confirm it as I am not confident. Better yet, why don't you call the iPage guys because they can assist you better...

Comment #1

Ugh...well at least I have company! if you figure it out let me know. This isn't my site, it's one I did for someone else, and I don't know why it isn't working except that maybe a path is wrong in the configure file (since it worked perfectly before. It's just not seeing the data in the database, but I can't seem to figure out why! the weird thing is that if you look at the opening screen for Admin, it shows Pending under orders and the correct number, but when you click on it, there's nothing in the order section...so it's recognizing them, but just not showing them!..

Comment #2

Double check your database itself, the orders_status table, see if it has entries or is empty. if empty then you can get that table from a backup and reimport it...

Comment #3

I am having a simmilar problem but I think everything started when I deleted english as a language. now I can't see products or categories in Admin but they are in the Database...

Comment #4

My Orders_status table doesn't have the newest orders in it (ie. the ones from after I installed UK Switch card contribution)... how I import an older copy in phpMyadmin?..

Comment #5

The only thing here is to take off the / at the end to give.

Define('DIR_FS_DOCUMENT_ROOT', '/home/pattibea/public_html');..

Comment #6

What is now the default language, I ask this as the order_status table has language_id set default 1 which is english so if you have deleted english then you no longer have language default 1.

If I guess that spanish is default language then you need to set the order_status table languages_id default to 3 which is what oscommerce has espanol language id set to...

Comment #7

Should I be checking the Orders_status table or the orders_status_history table? The orders_status table lists the 3 choices of status. the _history one has 5 orders in it (the orders table has 6 orders in it). They have the same order id numbers...

Comment #8

Well, I tried everything mentioned here and it's still not working. I tried replacing those tables with the working version, that didn't work. The info is there, it's just not showing in admin. If the paths are right in configure, is there somewhere else I should look? I tried uploading a clean copy of orders.php, but that didn't work. Gift Voucher purchases aren't showing either. Both functions worked perfectly locally, and the only changes I made once I uploaded them to the iPage site were to the configure files. I really need to get this working!..

Comment #9

I had that a few month ago, I played around with the language default. I hade the orders counting but not showing up so I deleted the language table and reimported it. now it works again!.

WARNING DO NOT TRY THIES AT HOME WITHOUT BACKUP.

This post has been edited by.

RobinsonDixon.

: 20 June 2004, 14:07..

Comment #10

Ok. there is nothing in the orders_total table, but I checked it on my own iPage site and there is info in that table...could this be the problem? Why would the info go into the orders table but not the orders_total table (if it is supposed to, i'm only making that assumption based on the fact that it is there in my own site). I don't know what could be causing that to happen since everything is exactly the same as it was locally, but if I at least had a clue where to look, I might be able to figure it out..

Thanks...

Comment #11

The details of my orders are in order_totals table... but they're still not showing in the admin for some strange reason - it just says unknown column 'comments' blah blah.....

Comment #12

My problems are all solved after hours of head scratching... I simply added the fields it couldn't find to the tables it was trying to access them from and everything seems to work sweetly.....

Comment #13

I recently had this problem and the issue was a faulty shipping module. Once I selected the UPS shipping module, all orders started showing up again. It didn't fix the problem of the ones which were created during the down-time, but those are easily re-created in the orders_total table..

Cheers!.

Brian..

Comment #14

I've done a search and I can't seem to find a thread that helps me. I'm sure it's something silly and simple, but I can't get it working..

The iPage site was working fine locally. The database worked, orders showed in admin, etc. I installed the GV contribution and it still worked fine. I uploaded the iPage site to the root rather than to a catalog folder and made the changes to the configure files (i think.

). I'm guessing this must be where the problem is. The orders show in the database if I look at phpMyAdmin, but they are not showing in the Orders section. The customer gets the confirmation email, etc. The Gift Vouchers also do not show (I'm figuring they are related to the same problem.) My only guess is that there is something wrong with the configure files. I tried to do them exactly as the old ones on the iPage site had been, just taking out the catalog part, but obviously I did something wrong.

Here are the configure files:.

Admin:.

//Define the webserver and path parameters.

// * DIR_FS_* = Filesystem directories (local/physical).

// * DIR_WS_* = Webserver directories (virtual/URL).

 define('HTTP_SERVER', 'http://www.pattibears.com'); // eg, http://localhost - should not be empty for productive servers.

 define('HTTP_CATALOG_SERVER', 'http://www.pattibears.com');.

 define('HTTPS_CATALOG_SERVER', '');.

 define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module.

 define('DIR_FS_DOCUMENT_ROOT', '/home/pattibea/public_html/'); // where the pages are located on the server.

 define('DIR_WS_ADMIN', '/admin/'); // absolute path required.

 define('DIR_FS_ADMIN', '/home/pattibea/public_html/admin/'); // absolute pate required.

 define('DIR_WS_CATALOG', '/'); // absolute path required.

 define('DIR_FS_CATALOG', '/home/pattibea/public_html/'); // absolute path required.

 define('DIR_WS_IMAGES', 'images/');.

 define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG'images/');.

 define('DIR_WS_INCLUDES', 'includes/');.

 define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

 define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

 define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG'includes/languages/');.

 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG'includes/languages/');.

 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG'images/');.

 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG'includes/modules/');.

 define('DIR_FS_BACKUP', DIR_FS_ADMIN'backups/');.

// define our database connection.

 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers.

 define('DB_SERVER_USERNAME', xxxxx);.

 define('DB_SERVER_PASSWORD', 'xxxxx');.

 define('DB_DATABASE', 'xxxxx');.

 define('USE_PCONNECT', 'false'); // use persisstent connections?.

 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'.

?>.

And the catalog one:.

// Define the webserver and path parameters.

// * DIR_FS_* = Filesystem directories (local/physical).

// * DIR_WS_* = Webserver directories (virtual/URL).

 define('HTTP_SERVER', 'http://www.pattibears.com'); // eg, http://localhost - should not be empty for productive servers.

 define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers.

 define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

 define('HTTP_COOKIE_DOMAIN', 'www.pattibears.com');.

 define('HTTPS_COOKIE_DOMAIN', '');.

 define('HTTP_COOKIE_PATH', '/');.

 define('HTTPS_COOKIE_PATH', '');.

 define('DIR_WS_HTTP_CATALOG', '/');.

 define('DIR_WS_HTTPS_CATALOG', '');.

 define('DIR_WS_IMAGES', 'images/');.

 define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

 define('DIR_WS_INCLUDES', 'includes/');.

 define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

 define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

 define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

 define('DIR_FS_CATALOG', '/home/pattibea/public_html/');.

 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

// define our database connection.

 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers.

 define('DB_SERVER_USERNAME', xxxxx);.

 define('DB_SERVER_PASSWORD', 'xxxxx');.

 define('DB_DATABASE', xxxxx);.

 define('USE_PCONNECT', 'false'); // use persistent connections?.

 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'.

?>.

I apologize in advance if it is something really dumb...i just can't see it, whatever it is! If you have any other suggestions of files I should look at, let me know! I thought the only files that needed to be changed were the configure files when you moved it to the root, but maybe i'm missing something..

Thanks!..

Comment #15

I have a similar problem with orders not showing in my admin section after installing the UK Switch card CCV contribution... but so far no one seems to have replied... probably something really simple in my case as well!..

Comment #16


This question was taken from a support group/message board and re-posted here so others can learn from it.