chrometweaks.org

Help with iPage domain and Google Sites host?

Click Here To View All Answers...


First off, Help with iPage domain and Google Sites host? Thanks for any comment. Second question of mine... Hey gang-.

I built a iPage site last year using 2.1 CVS that has run bulletproof for 10 months now (after many painful hours here and great help from HPDL)..

I'm now building a second iPage site using 2.2 MS2 but have run into this quirk:.

When I add a product to the catalog, then go to add attributes, the attributes I add to the product seem to show up in random order..

EX: I add jacket model 123 with available sizes of XS, S, M, L, XL, 2XL, 3XL.

When I view the item I just added in the catalog, my sizes are completely randomized! I have tried this several times to see if there is a pattern, but I can't find one. The sizes display differently every time..

I have also tried entering the attributes in both option ID and option name sort modes, but have no success..

Has anybody else seen this? I've only entered a few items so I can start over if need be. This may seem minor to some of you, but when surcharges come into play for various sizes, it really helps keep things tidy if the sizes are always in the proper order..

Thanks in advance,.

Mike..

Comments (68)

Good question... I dunno what is the right answer. I'll do some Googling and get back to you if I bump into an anything. You should email the people at iPage as they probably could help you..

Comment #1

Orren,.

I DL'd v1.02, but have had no luck in getting it installed. Not sure if you have looked at it yet, but the first SQL command in the contribution is getting kicked out. Unfortunately, I'm a little too green with SQL to ammend the syntax..

I know enough that it wants to alter the field 'tex0003_tester" within the table 'products_attributes' by adding 'sort_order'.

This cont. was written for MS1, and I'm using MS2. There is no tex0003_tester in MS2. Any suggestions?.

Aside from that, you are right. This cont. looks like it should clear up any problems I have been having, IF I can possibly get it configured..

Thanks again,.

Mike..

Comment #2

I'm having a problem with this contribution too - cannot match the text in the instruction file with the actual text I need to edit..

Has anyone done this contribution succesfully in MS2 and, if so, can I have a look at your file?!.

Thanks.

Zion..

Comment #3

Mike:.

I had this exact same problem, which caused many hours of frustration. I did, howeevr, finally arrive at a very simple solution..

First, I input all of my attributes. I had things such as buy2/get 1, buy3/get 2, whatever. When I was finally done, the attributes were in no practical order. What I did was then edit the option ID and their corresponding order in the tabel, instead of the attributes, and it fixed everything..

This post has been edited by.

Matpal.

: 24 February 2004, 20:15..

Comment #4

Mat -.

I'll certainly give this a try, but may I ask how many attributes you had? I'm pushing around 60 right now, and I'm really wondering the feasiblity of it. But since I'm between a rock and a hard place, I certainly can't argue with success....

Thanks for the heads up..

Mike..

Comment #5

Well, I only had 2-3 of each, so yeah, it might be a stretch for you. I do know it was the only thing that worked for me, though...

Comment #6

Hey gang-.

I built a iPage site last year using 2.1 CVS that has run bulletproof for 10 months now (after many painful hours here and great help from HPDL)..

I'm now building a second iPage site using 2.2 MS2 but have run into this quirk:.

When I add a product to the catalog, then go to add attributes, the attributes I add to the product seem to show up in random order..

EX: I add jacket model 123 with available sizes of XS, S, M, L, XL, 2XL, 3XL.

When I view the item I just added in the catalog, my sizes are completely randomized! I have tried this several times to see if there is a pattern, but I can't find one. The sizes display differently every time..

I have also tried entering the attributes in both option ID and option name sort modes, but have no success..

Has anybody else seen this? I've only entered a few items so I can start over if need be. This may seem minor to some of you, but when surcharges come into play for various sizes, it really helps keep things tidy if the sizes are always in the proper order..

Thanks in advance,.

Mike..

Comment #7

Mike.

You may have found this already,.

Product Attributes Sort Order v1.01 by Erik McCarty in contriutions, he just released an update. It works and will allow you to control the sort order in you drop down product choice boxes. It needs one tweak from it's as supplied version to display correctly..

In file osCommerce/catalog/456wyvern/includes/languages/english/products_attributes.php.

Add the line.

Define('TABLE_HEADING_OPT_SORT_ORDER', 'Sort Order');.

In the defines list..

Try it..

Comment #8


This question was taken from a support group/message board and re-posted here so others can learn from it.