chrometweaks.org

How can I promote my iPage page?

Click Here To View All Answers...


First of all How can I promote my iPage page? Thanks in advance for any answer. My other question... Hi Im hoping someone with a it more knowledge can shed some wisdom in my direction.

Im in the process of setting up my cart ...and ... Im moving hosting......and dumping an x-cart to move ot oscommerce.

The actual iPage domain of my existing iPage site dns still points to my old server( www.auntiebob.com ) untill everything is done on the new server......

Basically the cart is other than a couple of tweaks finished..except for ssl...

I have been installing and editing the iPage site and cart on the new host via a modified hosts file on my pc.

I have set up my secure iPage domain as a subdomain (secure.auntiebob.com) and I'm using a modified "A" record on the subdomain so it resolves properly...since that same subdomain also exists on my old hosting....

The new A record dns is resolving correctly and pointing secure.auntiebob.com to my new hosting....

If I go to my secure.auntiebob.com iPage domain it's working...no errors ect...it is configured correctly itself... and it shows the lock, and I have a modified index.html file sitting in the secure directory to verify it's the correct dns.

The relivent portion of my catalog/configure.php file is pasted below....

(the ssl cert is set up without the www..so the secure.auntiebob.com is correct).

Here is the problem..... whenever I get to the point where I hit the checkout button I get.

Https://secure.auntiebob.com/ab_cart/catalo...caoffnkij51nai0.

A 404 error Not Found.

The requested URL /ab_cart/catalog/checkout_shipping.php was not found on this server..

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request..

Now as far as I can see everything is looking as it should......can anyone give me a heads up?.

I have scanned the board for the better part of the day and after reading dozens of posts I cant find anything og the 404 error other than.

The folks that have "ssl true" rather than false when there isnt a cert...

And btw it's an adult site...so if you decide you want to see for yourself....heads up.

And regardless without modifying your hosts file you wont be in the right place anyway.....

Comments (11)

Yep, there are some iPage online coupons available. Great opportunity to save cash on iPage now. I suggest you to sign up for their newsletter so you can be notified of their most up-to-date promotional codes. They usually send them out once a month..

Comment #1

Hi,.

You are missing the https & http protocol from the secure and http cookies..

Define('HTTP_COOKIE_DOMAIN', 'www.URL addrwss.com');.

Define('HTTPS_COOKIE_DOMAIN', 'https://Secure URL address.com');.

Define('HTTP_COOKIE_PATH', '/');.

Define('HTTPS_COOKIE_PATH', '/');.

Define('DIR_WS_HTTP_CATALOG', '/');.

Define('DIR_WS_HTTPS_CATALOG', '/');.

Try it in the above method.

REgards..

Comment #2

Oops sorry for the many replies, the forum went down on me I did not think the reply would get through!..

Comment #3

Thanks Ill take lots of replies over none any day.

I tried it as you suggested and I get exactly the same result a 404 error..

Comment #4

Is the path to your secure catalog.

Https://secure.aunti...b_cart/catalog/.

This is what the configure file is reading it as...

Comment #5

Well that is a correct path as far as my secure iPage domain is concerned.

I havent seen anything anywhere in installing the cart about having to duplicate the file structiure in the secure folder or subdomain.

Anything I can find is simply point the cart to your secure folder or subdomain enable ssl and your pretty much done.

But on the other hand this is the first time I have ever actually tried to configure a carts ssl.

So earlier that did occur to me since it is a 404 error..and the cart is looking (according to the secure url in my browser ) for.

This subdirectory ab_cart/catalog/ at the end of.

Https://secure.aunti...b_cart/catalog/.

As you mentioned....

So I thought well maybe I'm supposed to go into my secure subdomain and recreate that folder structure..so I did and the result was exactly the same... and as I said I saw no-where any suggestion to do that....figured what the hell it cant hurt to try.... the result was exactly the same so I went back and delieted the directlries I had added..

Comment #6

I am pretty sure I saw a post about this type of thing a while ago..

I tried to pull up your catalog nonssl but that redirected to your main index.php.

Have you tired a search on the forum?..

Comment #7

Ive done nothing else for the last 12 hours including googeling my ass off.

I see lots of people that have the problem...but NO solutions.

Part of the problem is ssl and a 404 error "search" brings up dozens of posts about how it happens when you have ssl on and do NOT have a cert in place.

I have been wading thru them all day treying to get an answer.

And nothing...its all about the above..or the occasional post about trhis ..then they do not go back and post what the solution was...if they ever found one.....

Its been quite frustrating so far.....

And yup on that catalog nonssl ..its all about the modified hosts file.

This post has been edited by.

Brenwa.

: 14 August 2008, 09:43..

Comment #8

A long shot Bren but try this.

Define('HTTP_SERVER', ''http://auntiebob.com');.

Define('HTTPS_SERVER', ''https://secure.auntiebob.com');.

Define('ENABLE_SSL', true);.

Define('HTTP_COOKIE_DOMAIN', '.auntiebob.com');.

Define('HTTPS_COOKIE_DOMAIN', '.secure.auntiebob.com');.

Define('HTTP_COOKIE_PATH', '/ab_cart/catalog/');.

Define('DIR_WS_HTTPS_CATALOG', '/ab_cart/catalog/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Nic..

Comment #9

Thanks for the effort Nic....

..but that didnt do it...it took the cart down with a syntax error.

I did find this on the other hand in a post from a few years ago.

And the reply was.

Now there was again no follow up saying it was correct or incorrect.....

Anyone want to venture in on that?..

Comment #10

SOLVED.

The solution is a symbolic link from insecure to secure.

I sent the info (original quote below) to my host...and this was the reply.....

And it worked just perfect.....

So for folks in the future with this problem, who are searching.

This may sound a bit redundant..but I'm putting the paragraph below for search purposes.

Because finding anything on this was almost impossible.

If you are getting a 404 page error and you DO have a SSL in place.

Ssl is set to true, and there is a secure certificate, and it is functioning properly.

Secure certificate is in place and working, my configure.php is correct, but Im getting 404 errors.

At checkout and or account links.

Oscommerce dreamhost and ssl issues.

This issue seems to be host dependent, in my case my host (dreamhost) placed a separate directory in my home directory for my secure subdomain.

The solution was to create a symbolic ink to it.

You dont need to know what that is.. but your host will..if they dont...get a different host.....

It will take them about 2 min to fix the problem.....

Be aware the actual secure folder is deleted in the process and the "symbolic" link replaces it.

Post.

Reply..

Comment #11


This question was taken from a support group/message board and re-posted here so others can learn from it.