chrometweaks.org

How do I insert swf file in iPage?

Click Here To View All Answers...


Got a quick question: How do I insert swf file in iPage? Hoping for any answer. Second question.. Please help me!.

I have bought a virtual server and i'm migrating oscommerce to it but something wrong.. had many problems and cannot solve one of it because no errors shown..

When I try to open the admin panel, in place of showing the login panel, the page is redirecting continuously without stopping and firefox (ie too) brokes connection...

I have register_globals set to on via .htaccess.

And modified ALL $HTTP_xxx_VARS to $_xxx[] vars so haven't anymore problems with long global vars.

Maybe problem with sessions????.

I really don't know where to search for errors..

Please help me!!!..

Comments (18)

I would like to know the answer too. Anyone here know what is the answer to your question. I'll do some poking around and get back to you if I find an useful answer. You should email the people at iPage as they probably could answer your iPage question..

Comment #1

You haven't provided enough information to solve your problem. Is the catalog working??? Is it just the admin which is redirecting and if so, where is it redirecting to???.

Have you adjusted your configure.php files to reflect the new server such as where it says /myserver/public_html/ or something like that. That part is different on each server so they will need to be updated...

Comment #2

The catalog is working, seems to have problems with authentication, sessions are keeped on URL and doesn't change on every reload, so isn't sessions problem for frontend. On backend seems to continuously reload the login.php page, the filesystem path is correct I think, is the same for other domains (changing the name of account...), the big difference is that on old server I had register_globals on and the "use of $HTTP_xxx_VARS" (don't remember how is called) on, now I have set register_globals on via .htaccess on catalog and admin directories, and changed all the $HTTP_xxx_VARS to $_GET, $POST, and so on.. on old server all was running using php5 and mysql5, on the new one I vahe the problems I told you about..

If you need I can post the configure file.. but is the same as for frontend and there is running without problems. the only problem for frontend is for login...no errors are given, just reloads page and asks for user and pass again. On admin doesn't asks anything, just reloads continuously and firefox brokes connection..

I can send any page if will help for understanding problem...

Comment #3

Post your includes/configure.php file without the database info at the bottom..

Vger..

Comment #4

I am having a similar problem..

The admin login page keep reloading itself..

This is for an install that worked perfectly on a local machine and has been moved to a iPage hosting service (1and1)..

Admin configure file:.

Define('HTTP_SERVER', 'http://s247533021.onlinehome.us');.

Define('HTTP_CATALOG_SERVER', 'http://s247533021.onlinehome.us/catalog/');.

Define('HTTPS_CATALOG_SERVER', 'https://s247533021.onlinehome.us/catalog/');.

Define('ENABLE_SSL_CATALOG', 'false');.

Define('DIR_FS_DOCUMENT_ROOT', '/kunden/homepages/33/d247533006/htdocs/catalog/');.

Define('DIR_WS_ADMIN', '/catalog/admin/'); // good.

Define('DIR_FS_ADMIN', '/admin/');.

Define('DIR_WS_CATALOG', ''); // should be good.

Define('DIR_FS_CATALOG', '/kunden/homepages/33/d247533006/htdocs/catalog/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG'images/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG'includes/languages/');.

Define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG'includes/languages/');.

Define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG'images/');.

Define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG'includes/modules/');.

Define('DIR_FS_BACKUP', DIR_FS_ADMIN'backups/');.

Includes/configure file:.

Define('HTTP_SERVER', 'http://s247533021.onlinehome.us');.

Define('HTTPS_SERVER', 'http://s247533021.onlinehome.us');.

Define('ENABLE_SSL', false);.

Define('HTTP_COOKIE_DOMAIN', 'http://s247533021.onlinehome.us');.

Define('HTTPS_COOKIE_DOMAIN', 'http://s247533021.onlinehome.us');.

Define('HTTP_COOKIE_PATH', '/catalog/');.

Define('HTTPS_COOKIE_PATH', '/catalog/');.

Define('DIR_WS_HTTP_CATALOG', '/catalog/');.

Define('DIR_WS_HTTPS_CATALOG', '/catalog/');.

Define('DIR_WS_IMAGES', '/catalog/images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

Define('DIR_FS_CATALOG', '/catalog/'); // or /catalog/?.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

This post has been edited by.

Shelbyparts.

: 03 July 2008, 19:02..

Comment #5

Dp.

This post has been edited by.

Shelbyparts.

: 03 July 2008, 19:01..

Comment #6

Is it problem with admin or user side..

If admin side do You have admin access level control installed..

Satish..

Comment #7

Admin side.

Do you mean proper permissions on the remote server or a setting in OSC?..

Comment #8

If You ahve added files to admin section..

Then There is a table for admin files..

You need to add those file names to that table and associate a proper admin group ith it..

Satish..

Comment #9

Satish we both have this install running on other servers/computers so (for me) I have no different files or new files o database changes between two oscommerce installs.. thanks for your reply but is not helping me...

Comment #10

It appears I have corrected my session writing issues and my install is not returning any error msgs, but I still cannot login to admin. I cleared and re-added my admin and when I login it create and stores a new session, but the login page just refreshes..

The only thing I can figure is there is something still messed up on my admin configure file that keep directing me back to the login..

Define('HTTP_SERVER', 'http://s247533021.onlinehome.us');.

Define('HTTP_CATALOG_SERVER', 'http://s247533021.onlinehome.us/catalog/');.

Define('HTTPS_CATALOG_SERVER', 'https://s247533021.onlinehome.us/catalog/');.

Define('ENABLE_SSL_CATALOG', 'false');.

Define('DIR_FS_DOCUMENT_ROOT', '/kunden/homepages/33/d247533006/htdocs/'); //.

Define('DIR_WS_ADMIN', '/catalog/admin/'); // good.

Define('DIR_FS_ADMIN', '/kunden/homepages/33/d247533006/htdocs/catalog/admin/');.

Define('DIR_WS_CATALOG', '/catalog/'); // should be good.

Define('DIR_FS_CATALOG', '/kunden/homepages/33/d247533006/htdocs/catalog/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG'images/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG'includes/languages/');.

Define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG'includes/languages/');.

Define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG'images/');.

Define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG'includes/modules/');.

Define('DIR_FS_BACKUP', DIR_FS_ADMIN'backups/');..

Comment #11

You are kicked back for one of the following reason:.

1)Cookies are not getting stored in the browser or the cookie paths are not ok:.

For this view Your cookies and chek that it has a cookie with oscAdmin related cokie Id and a value.Plus it has not timed out..

2)The cookies are getting created but path and values are some what wrong..

3)Due to admin access level some page permission is not given..

4)Session or cookie timings are too less..

Satish..

Comment #12

I checked my browser....

The cookie is being created with a value and the path is /catalog/admin/ and is set to expire at the end of session..

Should my admin dir permissions be set to 644?.

Here is my non admin configure file:.

Define('HTTP_SERVER', 'http://s247533021.onlinehome.us');.

Define('HTTPS_SERVER', 'http://s247533021.onlinehome.us');.

Define('ENABLE_SSL', false);.

Define('HTTP_COOKIE_DOMAIN', 'http://s247533021.onlinehome.us');.

Define('HTTPS_COOKIE_DOMAIN', 'http://s247533021.onlinehome.us');.

Define('HTTP_COOKIE_PATH', '/catalog/admin/');.

Define('HTTPS_COOKIE_PATH', '/catalog/');.

Define('DIR_WS_HTTP_CATALOG', '/catalog/');.

Define('DIR_WS_HTTPS_CATALOG', '/catalog/');.

Define('DIR_WS_IMAGES', '/catalog/images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

Define('DIR_FS_CATALOG', '/catalog/');.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');..

Comment #13

Here is my non admin configure file:.

Define('HTTP_SERVER', 'http://s247533021.onlinehome.us');.

Define('HTTPS_SERVER', 'http://s247533021.onlinehome.us');.

Define('ENABLE_SSL', false);.

Define('HTTP_COOKIE_DOMAIN', 'http://s247533021.onlinehome.us');.

Define('HTTPS_COOKIE_DOMAIN', 'http://s247533021.onlinehome.us');.

Define('HTTP_COOKIE_PATH', '/catalog/');.

Define('HTTPS_COOKIE_PATH', '/catalog/');..

Comment #14

Have you checked the obvious? Is your .htaccess in the directory redirecting you?..

Comment #15

Here is my root level htaccess... everything is commented out. Every time I change or un comment something I get an internal server error..

I have no idea how to configure it. I moved everything from an apache webserver on a local XP machine to 1and1 Linux hosting..

# $Id: $.

#.

# This is used with Apache WebServers.

#.

# For this to work, you must include the parameter 'Options' to.

# the AllowOverride configuration.

#.

# Example:.

#.

# <Directory "/kunden/homepages/33/d247533006/htdocs"> ///// I changed this.

# AllowOverride Options.

# </Directory>.

#.

# 'All' with also work. (This configuration is in the.

# apache/conf/httpd.conf file).

# The following makes adjustments to the SSL protocol for Internet.

# Explorer browsers.

#<IfModule mod_setenvif.c>.

# <IfDefine SSL>.

# SetEnvIf User-Agent ".*MSIE.*" \.

# nokeepalive ssl-unclean-shutdown \.

# downgrade-1.0 force-response-1.0.

# </IfDefine>.

#</IfModule>.

# If Search Engine Friendly URLs do not work, try enabling the.

# following Apache configuration parameter.

# AcceptPathInfo On.

# Fix certain PHP values.

# (commented out by default to prevent errors occuring on certain.

# servers).

# php_value session.use_trans_sid 0.

# php_value register_globals 1..

Comment #16

I am still getting nowhere on this after going over all recommendations. I really dont think it's an .htaccess issue and the cookies are being written. When I delete the cookies in my browser and session in phpmyadmin, they are recreated as soon as I login again. Is there any way to turn on addition error reporting or logging so I can see what is going on?.

Have you had any luck Marco82?..

Comment #17

In some installs there is a.

Configure.php.

File in the.

/catalog/includes/local.

And/or the.

/admin/includes/local.

Folder(s)..

Check for these files..

If they are present, be certain they contain valid information. osC will use information from them...

Comment #18

I've done this and posted the syntax of said files in this thread..

Thanks for the tip though...

Comment #19


This question was taken from a support group/message board and re-posted here so others can learn from it.