chrometweaks.org

How do I remove the iPage banner from my website?

Click Here To View All Answers...


Got a question, hope someone can answer... How do I remove the iPage banner from my website? Hoping for any response. Another quick question... When I add this...

Require(DIR_WS_BOXES'loginbox.php');.

For instance, in the colum_right, header, anywhere, it automatically adds an additional table around it..

Is there any way to just let the include run, WITHOUT the extra table? Like for instance, just have it run within the box itself, not add a new beginning and end set for an extra table to where it is entered?.

Not sure if I am getting this across right, but I can hope.....

Comments (25)

I would like to know the answer too. Anyone here know what is the right answer. I'll do some investigation and get back to you if I discover an useful answer. You should email the people at iPage as they probably could give you an answer..

Comment #1

Does this work even if it is the first reference in the file to that particular infobox? Meaning, how can it echo something, that hasn't made a sound yet?..

Comment #2

I think that You would have to set up the table itself in the Column Left Area... After you make sure that the Function itself does not make extra tables....

Maybe it's doing like "make a table in the function, then it makes another table in the COlumn Left .php...

Take your time and check it over....

Think Your Smart, Solve This..

Comment #3

LOL looks like someone replied before I got my edit in.

Questioning ya Aziz before I go to my dilema...

The problem is, I do not WANT it in the column left or column right..

I am trying to move something away from both of those places, and put it elsewhere on the page, and still be able to retain the functionality that it had in the infobox itself, without actually having it have the stupid header for it. And without it creating it's own table that throws off the alignment for everything else with it doing that when it is aded..

I am trying to edit that file now, and I am going bananas here..

I am getting an error on this line....

<table border="0" width="100%" cellspacing="0" cellpadding="0">.

And I have NO idea why!.

IT keeps telling me there is a parse error there, but I cannot see anything that it could be..

Only thing I can think of is that there is something wrong with the lines before it..

This are those few lines..

<?php.

$info_box_contents = array();.

$info_box_contents[] = array('align' => 'left',.

'text' => HEADER_TITLE_LOGIN.

);.

Echo $info_box_contents, false, false);.

$loginboxcontent = ".

<table border="0" width="100%" cellspacing="0" cellpadding="0">.

Can anyone see anything, referring to the posts above as to how to get rid of the table being added, that could possibly be causing this???..

Comment #4

First Mistake: echo $info_box_contents, false, false); , THere is only One ")"???.

Second Mistake: $loginboxcontent = " > missing an ".

Third thing, If you want to make, lets say a login prompt for the user and not use the infobox attributes then you just make a simple form whereever you want to make the login prompt and send the login page the Values of the login...

If you want to stick it to the infobox functionality then they all have to be applied, with the table.

Salam,..

Comment #5

Oops.

I forgot I had edited that and edited it back again..

This is the whole section of code, CORRECTLY lol.

What I am trying to do, is move the Loginbox, that keeps the logged in info in the box, to a different area other than the columns..

The only thing I can think of, is that when you change the original, which is.

<?php.

   $info_box_contents = array();.

   $info_box_contents[] = array('align' => 'left',.

                                'text'  => HEADER_TITLE_LOGIN.

                               );.

   new infoBoxHeading($info_box_contents, false, false);.

   $loginboxcontent = ".

Table added here, full code in next paste.

To this.

<?php.

   $info_box_contents = array();.

   $info_box_contents[] = array('align' => 'left',.

                                'text'  => HEADER_TITLE_LOGIN.

                               );.

 echo $info_box_contents, false, false;.

   $loginboxcontent = ".

            <table border="0" width="100%" cellspacing="0" cellpadding="0">.

           <form name="login" method="post" action="\"tep_href_link(FILENAME_LOGIN, 'action=process', 'SSL')"\">.

             <tr>.

               <td align="left" class="boxText">.

                 "ENTRY_EMAIL_ADDRESS".

               </td>.

             </tr>.

             <tr>.

               <td align="left" class="boxText">.

                 <input type="text" name="email_address" maxlength="96" size="10" value="\">.

               </td>.

             </tr>.

             <tr>.

               <td align="left" class="boxText">.

                 "ENTRY_PASSWORD".

               </td>.

             </tr>.

             <tr>.

               <td align="left" class="boxText">.

                 <input type="password" name="password" maxlength="40" size="10" value="\">.

               </td>.

             </tr>.

             <tr>.

               <td align="center" class="boxText">.

                 "tep_image_submit('button_login.gif', IMAGE_BUTTON_LOGIN, 'SSL')".

               </td>.

             </tr>.

           </form>.

           </table><BR>.

"tep_draw_separator('pixel_trans.gif', '9', '4')"<BR><A HREF="\"tep_href_link(FILENAME_PASSWORD_FORGOTTEN, '', 'SSL')"\">"LOGIN_BOX_PASSWORD_FORGOTTEN"</A>.

             ";.

   $info_box_contents = array();.

   $info_box_contents[] = array('align' => 'center',.

                                'text'  => $loginboxcontent.

                               );.

   echo $info_box_contents;.

?>.

I miss something, somewhere..

The second ' is after the table and begins the next line after it..

And making hte login box does not work with the whole setup that is there now, which I want to keep. Unless the login was completely wrong, it would not let the rest of the info go..

I have tried just about everything me, and some other people I consider Gurus could think of, and nothing made it work or line right. So it has to be something very simple. Thats why I want to just make it so that it has a little change as possible, get rid of the table and header, and just use an include to keep the functions I already have, just put it where I WANT it to be, yanno?.

This post has been edited by.

Tariq.

: 13 February 2004, 01:52..

Comment #6

To tell you the truth this is my first day dealing with OScommerce.

Soon when I have dealt with it enough I will try to help You...

All I can thinks I can do is to try to make the login completly separate from the infobox....

Sometimes It just take a while to get things in mind....

(im a slow thinker).

Sorry man, If I ever get anything I will come back.

Salam,..

Comment #7

Lol it's ok hun..

I spent a LOT of time in here when I first started, and I had NO knowledge of PHP, or anything else involved with OSC :>.

Im still way a newbette but at least Im not a completely lost newbette..

Comment #8

When I add this...

Require(DIR_WS_BOXES'loginbox.php');.

For instance, in the colum_right, header, anywhere, it automatically adds an additional table around it..

Is there any way to just let the include run, WITHOUT the extra table? Like for instance, just have it run within the box itself, not add a new beginning and end set for an extra table to where it is entered?.

Not sure if I am getting this across right, but I can hope.....

Comment #9

Inside the file includes/boxes/loginbox.php, I suspect that it says something like new infoBox($infobox_contents); The new infoBox contains the table. If you do not want that table, try echo $infobox_contents instead (or whatever the variable is)..

Hth,.

Matt..

Comment #10


This question was taken from a support group/message board and re-posted here so others can learn from it.