chrometweaks.org

How the heck do I set up my iPage website ?!?

Click Here To View All Answers...


My first question is How the heck do I set up my iPage website ?!? Thanks in advance for any comment. 2nd question I got is.. Hello I am having massive problems with my cart, it seems that when it switches to the secure.networking-help.biz it loses the info or something. I have had several different ppl from different locations test this and they are getting the same error on my cart. It seems to work when it wants. If someone can please help me that would be great or even create and account to see what it is doing..

My cart is.

Http://www.networking-help.biz/store.

My secure SSL is.

Https://secure.networking-help.biz.

I am going crazy because the cart is almost populated with actual items..

Thanks.

David Rodriguez..

Comments (98)

Hmm... I need to find out myself. I don't know what is the right answer. I'll do some research and get back to you if I find an answer. You should email the people at iPage as they probably could assist you..

Comment #1

Yeah that sounds right, I didn't even think about that. Thanks alot. I am going to change that tonite..

David Rodriguez..

Comment #2

Man I am totally bumed, went to change my ssl and got this messege:.

Set up a Dedicated SSL Certificate from GeoTrust for one of your domains..

Once a Dedicated SSL Certificate is set up for a iPage domain or subdomain, encoded data transfer is possible. With 128-bit encoding, sensitive data can be protected during transfer from attempts at spying or manipulation..

Please note: No forwarding destination may be set for this domain. Forwarding an encoded transfer to an external URL is not possible..

To find out more information on GeoTrust please visit.

Http://www.geotrust.com/.

..

The certificate for the iPage domain secure.networking-help.biz is ready..

The certificate cannot be applied to a different iPage domain before 3/17/2004...

Comment #3

This could be a cookie problem in configure.php.

Does your configure.php look like this? If not give it a try..

 .

Define('HTTP_COOKIE_DOMAIN', 'networking-help.biz');.

Define('HTTPS_COOKIE_DOMAIN', 'networking-help.biz');.

Define('HTTP_COOKIE_PATH', '/store/');.

Define('HTTPS_COOKIE_PATH', '/store/');..

Comment #4

It should be like this if you cant change it..

Define('HTTP_SERVER', 'http://www.networking-help.biz');.

Define('HTTPS_SERVER', 'https://secure.networking-help.biz');.

Define('ENABLE_SSL', true);.

Define('HTTP_COOKIE_DOMAIN', 'www.networking-help.biz');.

Define('HTTPS_COOKIE_DOMAIN', 'secure.networking-help.biz');.

And set Force Cookies to False..

Comment #5

Wow, this is hard then I thought, I have made the changes, I will list them below. Its doing the same thing. I feel I am getting closer to thinking this us with all the help you guys are giving..

This is what I currently have it set to now after the last reply I got..

Define('HTTP_SERVER', 'http://www.networking-help.biz'); // eg, http://localhost -.

Define('HTTPS_SERVER', 'https://secure.networking-help.biz'); // eg, https://localhost -.

Define('ENABLE_SSL', true); // secure webserver for checkout procedure?.

Define('HTTP_COOKIE_DOMAIN', 'www.networking-help.biz');.

Define('HTTPS_COOKIE_DOMAIN', 'www.networking-help.biz');.

Define('HTTP_COOKIE_PATH', '/store/');.

Define('HTTPS_COOKIE_PATH', '/store/');.

Define('DIR_WS_HTTP_CATALOG', '/store/');.

Define('DIR_WS_HTTPS_CATALOG', '/store/');.

These are the session settings:.

Session Directory /tmp.

Force Cookie Use False.

Check SSL Session ID True.

Check User Agent True.

Check IP Address True.

Prevent Spider Sessions False.

Recreate Session False.

Session Directory.

Thanks for your help...

Comment #6

I am having a similar problem, but it would appear this situation refers to MS2 and I am using MS1 as it is only one supporting Japanese..

I have several shopping sites that were all working fine until the sites were moved to a new server. Now all of them are dropping the items from the shopping cart when they switch to SSL mode..

No where in the configure.php file does it mention cookies in MS1..

It could be the SSL address has changed, but if this was the case then I would have thought I would have received an error...

Comment #7

Details of MS1 configure.php file.

// Define the webserver and path parameters.

// * DIR_FS_* = Filesystem directories (local/physical).

// * DIR_WS_* = Webserver directories (virtual/URL).

Define('HTTP_SERVER', 'http://hotelgaido.com');.

Define('HTTPS_SERVER', 'https://safessl.net/~hotel');.

Define('ENABLE_SSL', true); // secure webserver for checkout procedure?.

Define('DIR_WS_CATALOG', '/contax/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG'pub/');.

Define('DIR_FS_DOCUMENT_ROOT', $HTTP_SERVER_VARS['DOCUMENT_ROOT']); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs).

Define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOTDIR_WS_CATALOG);.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

// define our database connection.

Define('DB_SERVER', 'localhost');.

Define('DB_SERVER_USERNAME', 'hotel_osc1');.

Define('DB_SERVER_PASSWORD', '********');.

Define('DB_DATABASE', 'hotel_osc1');.

Define('USE_PCONNECT', 'false'); // use persistent connections?.

Define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'.

?>..

Comment #8

Looks like it was a problem with the SSL at the server end...

Comment #9

Hello I am having massive problems with my cart, it seems that when it switches to the secure.networking-help.biz it loses the info or something. I have had several different ppl from different locations test this and they are getting the same error on my cart. It seems to work when it wants. If someone can please help me that would be great or even create and account to see what it is doing..

My cart is.

Http://www.networking-help.biz/store.

My secure SSL is.

Https://secure.networking-help.biz.

I am going crazy because the cart is almost populated with actual items..

Thanks.

David Rodriguez..

Comment #10

OK, I've had a little play and my guess is........it's because you have used a diff sub iPage domain for you secure billing to the catalog pages. i.e. when I go to the store I'm first taken to www.networking-help.biz/store then when you want to login or pay I am taken to secure.networking-help.bizI'm thinking that this is basically because the info isnt carried over to the subdomain. All secure carts that I know of dont work on a diff subdomain. It should be the same iPage domain as the cart. so your secure URL should be:.

Https://www.network-help.biz.

Take extra note of the s on the end of http because it means secure. So if you can do this, then it'll be sorted!..

Comment #11


This question was taken from a support group/message board and re-posted here so others can learn from it.