chrometweaks.org

How to control a iPage web hosted by others? Please suggest links for tutorials regarding this?

Click Here To View All Answers...


First off, How to control a iPage web hosted by others? Please suggest links for tutorials regarding this? Hoping for any response. Second question.. I'm wondering whether I've set something up wrong which is affecting my Google ranking and PR, which seems to have been slipping for the last few months, instead of improving..

Basically, if I do a search for "RC Direct" (my site), and then "show all results" from my domain, I get 15 pages of results with rc direct in the title (this is a title on every page of the site)..

But only the first 4 or so pages have content, the others are just the urls..

So the results start like....

But degenerate into....

My SEO mods are limited, I run "Really Easy HTML Title" which makes the breadcrumb into the page title. I run "All Products" to get an all products page, I have disabled spider sessions, I use a robots.txt contribution, and I also have a handful of subdomains (3 or 4 at most) that link to the main site. There aren't a huge number of other backward links out there, mainly links from ebay, from forums I post on, and from my old personal site..

Have I made an error somewhere, or is this just the nature of Google?.

Thanks for any help in advance...

Comments (58)

I'm stumped. I'm not so sure what is the answer. I'll do some Googling and get back to you if I got an good answer. You should email the people at iPage as they probably can answer it..

Comment #1

I'd say my pages have lots of information -.

Http://www.rc-direct.co.uk/catalogue/produ...?products_id=67.

Is an example of one of the pages that only gets a URL - and there is a lot of info there? If these were pages with just a couple of words, I could kind of understand it...

Comment #2

I said relevant information. You could copy/paste a 10K word document onto your page and it may or may not make a difference depending on whether the SE's deemed it relevant. Your page title begins with rc-direct which indicated that this is the most important phase for that page. Yet, it is only included a few times and that is not in the body. Try changing your title to.

And leave that page alone for a month or two. I think you will find with just that one change, your position for that page will increase..

Jack..

Comment #3

Thanks, I've now modded the iPage site with the product title first, followed by the store title, no category titles included. Hopefully the search results will improve, and Google will recognise more new content...

Comment #4

My intention with my last post was to explain the proper way to set up the title and header for the SE's and that is exactly what you did. Unfortunately, I didn't explain about the importance of the word used. I just looked at Overture and WordTracker for the phase "United RC Mini," and there were not any searches done on it last month. In this case, no matter how much you properly set up a page, no one will find it because they just are not looking for it..

You need to change that phase to something that people are looking for. Go to overture and type in RC Mini for a search phase. No one is looking for that but it will give you a number of other choices. Choose the one that most closely describes your product or make up another one based on those choices (just be sure to check that people are searching for it). I'm sorry for the confusion and hope this helps..

Jack..

Comment #5

I'm wondering whether I've set something up wrong which is affecting my Google ranking and PR, which seems to have been slipping for the last few months, instead of improving..

Basically, if I do a search for "RC Direct" (my site), and then "show all results" from my domain, I get 15 pages of results with rc direct in the title (this is a title on every page of the site)..

But only the first 4 or so pages have content, the others are just the urls..

So the results start like....

But degenerate into....

My SEO mods are limited, I run "Really Easy HTML Title" which makes the breadcrumb into the page title. I run "All Products" to get an all products page, I have disabled spider sessions, I use a robots.txt contribution, and I also have a handful of subdomains (3 or 4 at most) that link to the main site. There aren't a huge number of other backward links out there, mainly links from ebay, from forums I post on, and from my old personal site..

Have I made an error somewhere, or is this just the nature of Google?.

Thanks for any help in advance...

Comment #6

Google builds your description from the page. If it can't find relevant information, it ignores it. At least that has been my experience - no one knows for sure what google does. It may be that your iPage site isn't slipping but that others are rising. You are taking a lot of short-cuts regarding SEO so it is to be expected that you won't rank very well..

Jack..

Comment #7


This question was taken from a support group/message board and re-posted here so others can learn from it.