chrometweaks.org

.htaccess is not updating on my website. I use iPage's Windows Economy Hosting.?

Click Here To View All Answers...


First question I have is .htaccess is not updating on my website. I use iPage's Windows Economy Hosting.? Many thanks for any answer or 2. Second question of mine... My problem is that if a customer adds a product from product_info.php, then the shopping cart is empty..

I've searched the forums and have seen that possibly a configure issue with setting the proper cookie paths. tried that in many different possibilities. but no luck..

But hear's my catalog/configure.php code:.

 define('HTTP_SERVER', 'http://my-site.com');.

 define('HTTPS_SERVER', 'https://my-site.com');.

 define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

 define('HTTP_COOKIE_DOMAIN', '/catalog/');.

 define('HTTPS_COOKIE_DOMAIN', '/catalog/');.

 define('HTTP_COOKIE_PATH', '/catalog/');.

 define('HTTPS_COOKIE_PATH', '');.

Any suggestions would be great..

Didn't mean to cross post with tips and tricks, spaced out originally and put in wrong forum. thread is best here then there..

Best...

Comments (78)

I'm stumped. I'm not so sure what is the right answer. I'll do some research and get back to you if I find an answer. You should email the people at iPage as they probably know..

Comment #1

I've got both the HTTP and HTTPS in mine and works perfectly...

Comment #2

<<<I've got both the HTTP and HTTPS in mine and works perfectly.>>>.

Yes, it will..

But it doesn't ask for the protocol to use to access that domain, it asks for the iPage domain to associate the cookies with for the protocol HTTP, and then also for HTTPS. the actual correct way is to just list the iPage domain names, don't add the protocol used...

Comment #3

Thanks for the help and code suggestions..

I've changed configure.php to the following:.

 define('HTTP_SERVER', 'http://my-site.com');.

 define('HTTPS_SERVER', 'https://my-site.com');.

 define('ENABLE_SSL', true); // secure webserver for checkout procedure?.

 define('HTTP_COOKIE_DOMAIN', 'my-site.com');.

 define('HTTPS_COOKIE_DOMAIN', 'my-site.com');.

 define('HTTP_COOKIE_PATH', '/catalog/');.

 define('HTTPS_COOKIE_PATH', '/catalog/');.

 define('DIR_WS_HTTP_CATALOG', '/catalog/');.

 define('DIR_WS_HTTPS_CATALOG', '/catalog/');.

But still an empty cart..

This error began after an upgrade to 2.2ms. before upgrade, cart worked fine, after upgrade cart remains empty..

Is there any difference between HTTP_GET_POSTS functions in 2.2ms that may cause this pesky error, or is simply a cookie issue ? .

Best and as usual my thanks for the assistance...

Comment #4

Hi,.

Works vs Correct are 2 different things a "DOMAIN' does not include http:// thats a URL..

@fishy.

I dont know what might go wrong with upgrade so I suggest you do some searches or make a new thread stating it stoped working after upgrading..

Since 'my-site.com' is kinda vague lets try a better example to make sure if you use the www subdomain you also do cookies the same..

Define('HTTP_SERVER', 'http://www.mydomain.com');.

Define('HTTPS_SERVER', 'https://www.mydomain.com');.

Define('ENABLE_SSL', true);.

Define('HTTP_COOKIE_DOMAIN', 'www.mydomain.com');.

Define('HTTPS_COOKIE_DOMAIN', 'www.mydomain.com');.

You can test cookies by setting your browser to prompt you for cookies and chek the session id in the cookie or is it in the URL..

You can check the session path and settings in admin and see if they are correct..

HTH.

Dave.....

Comment #5

Im very much a newbie, but had the same prob..

I changed my code as follows and now it works like a dream:.

Define('ENABLE_SSL', true); // secure webserver for checkout procedure?.

Define('HTTP_COOKIE_DOMAIN', 'http://your site.com');.

Define('HTTPS_COOKIE_DOMAIN', 'https://your site.com');.

Define('HTTP_COOKIE_PATH', '/catalog/');.

Define('HTTPS_COOKIE_PATH', 'http://your secure server/~your user name') define('DIR_WS_HTTP_CATALOG', '/catalog/');.

Define('DIR_WS_HTTPS_CATALOG', '/catalog/');.

This is the line that made the difference:.

Define('HTTPS_COOKIE_PATH', 'http://your secure server/~your user name').

As my host HPPS server is a different name ie xxxx.srv.com and needs a username with a ~ before it..

Hence xxxx.srv2.com/~xxxxxxxx.

Sounds garbled but may help.

G..

Comment #6

Thanks to all for your help/suggestions..

I've gone a different route and loaded a fresh build, restored my database and are using .htaccess redirects..

It was a long over-due switch, the original osc directory was an unattractive looking directory name..

So much better now and orders have commenced..

Thanks,..

Comment #7

My problem is that if a customer adds a product from product_info.php, then the shopping cart is empty..

I've searched the forums and have seen that possibly a configure issue with setting the proper cookie paths. tried that in many different possibilities. but no luck..

But hear's my catalog/configure.php code:.

 define('HTTP_SERVER', 'http://my-site.com');.

 define('HTTPS_SERVER', 'https://my-site.com');.

 define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

 define('HTTP_COOKIE_DOMAIN', '/catalog/');.

 define('HTTPS_COOKIE_DOMAIN', '/catalog/');.

 define('HTTP_COOKIE_PATH', '/catalog/');.

 define('HTTPS_COOKIE_PATH', '');.

Any suggestions would be great..

Didn't mean to cross post with tips and tricks, spaced out originally and put in wrong forum. thread is best here then there..

Best...

Comment #8

Define('HTTP_COOKIE_DOMAIN', '/catalog/');.

Change to:.

Define('HTTP_COOKIE_DOMAIN', 'http://my-site.com');.

_________________________________________________________________.

Define('HTTPS_COOKIE_DOMAIN', '/catalog/');.

Change to:.

Define('HTTPS_COOKIE_DOMAIN', 'https://my-site.com');.

________________________________________________________________.

Define('ENABLE_SSL', false);.

Change to:.

Define('ENABLE_SSL', true);.

________________________________________________________________.

Define('HTTPS_COOKIE_PATH', '');.

Change to:.

Define('HTTPS_COOKIE_PATH', '/catalog/');.

This post has been edited by.

Zoomer.

: 29 February 2004, 18:31..

Comment #9


This question was taken from a support group/message board and re-posted here so others can learn from it.