chrometweaks.org

I want to create a host for my server in iPage....?

Click Here To View All Answers...


Got a question, hope someone can answer... I want to create a host for my server in iPage....? Thanks for any answer or 2. Another question... I have tried so many solutions on this one subject but still can't seem to get it right. The problem is that I started with 2.1MS2, a working cart currently making sales of around $700.00 week. I needed to add the gift voucher contribution which I did and quickly realized that the latest version of Gift Voucher will not work with version 2.1 as it needs to utilize filenames.php which is not in the 2.1 version..

I quickly created another folder of shop2 in my web iPage site root path and uploaded and assembled a clean version of 2.2MS2 off of the OSCommerce site. I have added only minimal modifications in the way of table header images, BG Colors and left and right column re organization. Nothing that would degrdate the login process..

I created a new databse using the 2.1 version and used the upgrade script to upgrade the database to 2.2 version with all of my current information from 2.1 ersion in it. All went smooth with no errors..

If I go to login on the shop2 it sends me to a 404 error page not found. I am in dire need of 2.2 MS2 as this will allow me the modifications flexibility for some of the great contributions out there. Can anyone help me through this one..

I appreciate any advice or guidance on this one..

Thank you.

See my Broken login script here!, create an account etc..

JM.

This post has been edited by.

Paycheck.

: 05 May 2004, 13:27..

Comments (99)

Hmm... I need to find out myself. I don't know what is the right answer to your question. I'll do some poking around and get back to you if I find an answer. You should email the people at iPage as they probably can answer it..

Comment #1

Creation of user account was possible (despite a few javascript errors).

BUT you have SSL enabled and your ssl-enabled shop seems not to know my login as it uses probably a different database then your shop2 ?

Comment #2

Post your configure.php files here without the database username, password, etc. could be something there...

Comment #3

<?php.

/*.

OsCommerce, Open Source E-Commerce Solutions.

Http://www.oscommerce.com.

Copyright © 2003 osCommerce.

Released under the GNU General Public License.

*/.

// Define the webserver and path parameters.

// * DIR_FS_* = Filesystem directories (local/physical).

// * DIR_WS_* = Webserver directories (virtual/URL).

Define('HTTP_SERVER', 'http://surfcamp.com'); // eg,.

Http://localhost.

- should not be empty for productive servers.

Define('HTTPS_SERVER', 'https://source2.ez-web-hosting.com'); // eg,.

Https://localhost.

- should not be empty for productive servers.

Define('ENABLE_SSL', true); // secure webserver for checkout procedure?.

Define('HTTP_COOKIE_DOMAIN', 'surfcamp.com');.

Define('HTTPS_COOKIE_DOMAIN', 'surfcamp.com');.

Define('HTTP_COOKIE_PATH', '/shop2/');.

Define('HTTPS_COOKIE_PATH', '/shop2/');.

Define('DIR_WS_HTTP_CATALOG', '/shop2/');.

Define('DIR_WS_HTTPS_CATALOG', '/~surfcamp/shop2/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

Define('DIR_FS_CATALOG', '/home/surfcamp/public_html/shop2/');.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

// define our database connection.

Define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers.

Define('DB_SERVER_USERNAME', 'xxxxxxx');.

Define('DB_SERVER_PASSWORD', 'xxxxxxx');.

Define('DB_DATABASE', 'surfcamp_shop2');.

Define('USE_PCONNECT', 'false'); // use persistent connections?.

Define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'.

?>.

I am thinking now that you brought this up could it be the cookies path to the secure server? That is all I can see. The DB is correct and I know the username and password were correct. Thanks so much for your help on this one..

JM..

Comment #4

This is the path that is being generated in teh Csid when I try to login..

It reads correct..

Https://source2.ez-web-hosting.com/~surfcam...8a3b3fcd6fb9a41..

Comment #5

Add the defines in /includes/apptication_top.php. The same with the table defines..

This post has been edited by.

Fl70.

: 05 May 2004, 21:59..

Comment #6

Have you actually used gift voucher on 2.1MS2 ? I will try this but I thought it had to do with something deeper than a simple link issue. I will try thought thank you.

JM..

Comment #7

Yes, your https path is what is probably causing things. what I dont understand is how this:.

Https://source2.ez-web-hosting.com.

Actually gets to you. there should be an alias, he needs to be.

Https://source2.ez-w...g.com/~surfcamp.

Define('HTTPS_SERVER', 'https://source2.ez-web-hosting.com/~surfcamp');.

Cookies should also point to source2, as they are probably getting lost in the transition..

Comment #8

Nice catch yuou are absolutely right.

I missed that.

JM..

Comment #9

Dude your an eagle eye, thanks, I guess I just am staring at this stuff too liong..

It works great now. Now I can convert my cart over..

Bitchin.

JM..

Comment #10

I have tried so many solutions on this one subject but still can't seem to get it right. The problem is that I started with 2.1MS2, a working cart currently making sales of around $700.00 week. I needed to add the gift voucher contribution which I did and quickly realized that the latest version of Gift Voucher will not work with version 2.1 as it needs to utilize filenames.php which is not in the 2.1 version..

I quickly created another folder of shop2 in my web iPage site root path and uploaded and assembled a clean version of 2.2MS2 off of the OSCommerce site. I have added only minimal modifications in the way of table header images, BG Colors and left and right column re organization. Nothing that would degrdate the login process..

I created a new databse using the 2.1 version and used the upgrade script to upgrade the database to 2.2 version with all of my current information from 2.1 ersion in it. All went smooth with no errors..

If I go to login on the shop2 it sends me to a 404 error page not found. I am in dire need of 2.2 MS2 as this will allow me the modifications flexibility for some of the great contributions out there. Can anyone help me through this one..

I appreciate any advice or guidance on this one..

Thank you.

See my Broken login script here!, create an account etc..

JM.

This post has been edited by.

Paycheck.

: 05 May 2004, 13:27..

Comment #11


This question was taken from a support group/message board and re-posted here so others can learn from it.