chrometweaks.org

I want to stop the filth sent to me via iPage?

Click Here To View All Answers...


Quick question... I want to stop the filth sent to me via iPage? Hoping for any response. Second question.. Background.

Have been developing my iPage website over a period time under localhost. At the start of the yearI drop my laptop, so had to reinstall on xp pc. I managed to get the iPage website on to a host. then my xp pc died..

Have just managed to get iPage website created on new vista business laptop. Has been a stop start year working on iPage website so have been a bit lost.

Issue.

Admin under localhost appear as I would expect, but are finding I am unable to make any changes, ie I can not added any products or new categories. I get no error messages.

Sorry is I have not explained this well. I am happy to provide information at can assited in resolving the issue I have.

Thanking everyone in advance..

Comments (98)

Hmm... I need to find out myself. I don't know what is the right answer to your question. I'll do some Googling and get back to you if I bump into an useful answer. You should email the people at iPage as they probably know..

Comment #1

[quote name='pubdomains.com' date='Oct 6 2008, 11:40 PM' post='1317777'].

Check PHP settings, typically safe mode, register_globals etc may be different and thus values are not getting captured & inserted in database..

Gaurav thanks for your reply,.

Where and what should I be looking at in php and what variables should I set.

Thanking you all in Advance..

Comment #2

Hello.

Give this a try.

Includes/functions/compatibility.php and admin/includes/functions/compatibility.php.

Function do_magic_quotes_gpc(&$ar) {.

If (!is_array($ar)) return false;.

While (list($key, $value) = each($ar)) {.

If (is_array($ar[$key])) {.

Do_magic_quotes_gpc($ar[$key]);.

} else {.

$ar[$key] = addslashes($value);.

}.

}.

Reset($ar);.

}.

Make sure that reset($ar); is there...

Comment #3

I made the required change. Now pages are not being displayed.

Thanking you all in advance..

Comment #4

OK try and comment them all out.

//function do_magic_quotes_gpc(&$ar) {.

//if (!is_array($ar)) return false;.

//while (list($key, $value) = each($ar)) {.

//if (is_array($ar[$key])) {.

//do_magic_quotes_gpc($ar[$key]);.

//} else {.

//$ar[$key] = addslashes($value);.

//}.

//}.

//reset($ar);.

//}.

Nic..

Comment #5

When I tried I got.

HTTP 500 Internal server error.

Removed the above change.

Examples of text I am see on the eg Admin cataloge.

TEXT_DATE_ADDED 11/05/2005.

TEXT_IMAGE_NONEXISTENT.

2981-blk-85.jpg.

TEXT_SUBCATEGORIES 5.

Clicking on another info button nothing happens.

Under the configuration menu, changing say from My Store to Product Listing nothing changes in what is displayed.

Thnaking you all in advance..

Comment #6

I have found the following topic 269431.

"if I try to insert or update Categories or to delete Products or Categories absolutely nothing happens: No Changes where made in the Database and no Error-Message is displayed. Everything else in the Shop seems to be OK".

Their solution was.

"Damn Vista and it's weird user permissions. Although I was logged on as an administrator it was using my 'user' account which only had read access to the configuration files - oscommerce could not write the correct information to the file. I corrected this by adding myself (again!) to each of the config files as a user with complete rights. That solved my issue. ".

Can someone explain to me (dummies guide) what extactly I need to do..

Comment #7

Still no luck resolving this issue..

Any members that have installed oscommerce under Vista - any special instructions.

Thanking you in advance..

Comment #8

Have found solution.

In php.ini I have set.

Register_long_arrays = On..

Comment #9

Background.

Have been developing my iPage website over a period time under localhost. At the start of the yearI drop my laptop, so had to reinstall on xp pc. I managed to get the iPage website on to a host. then my xp pc died..

Have just managed to get iPage website created on new vista business laptop. Has been a stop start year working on iPage website so have been a bit lost.

Issue.

Admin under localhost appear as I would expect, but are finding I am unable to make any changes, ie I can not added any products or new categories. I get no error messages.

Sorry is I have not explained this well. I am happy to provide information at can assited in resolving the issue I have.

Thanking everyone in advance..

Comment #10

Check PHP settings, typically safe mode, register_globals etc may be different and thus values are not getting captured & inserted in database..

Do an echo on the form you submit to check if any variable was captured (like new category) - and what output did you get, if it shows blank - you need to identify why the form values didn't come through...

Comment #11


This question was taken from a support group/message board and re-posted here so others can learn from it.