chrometweaks.org

I whante to delecte my page web to iPage?

Click Here To View All Answers...


First of all I whante to delecte my page web to iPage? Thanks in advance for any comment. 2nd question I got is.. Hello everyone =) Hope you had a great weekend!.

Please help me out here if you can. I am at a complete loss as how to fix or correct this problem..

I am getting this error when testing my cart checkout process:.

1146 - Table 'mycart.orders_products_attributes' doesn't exist.

Insert into orders_products_attributes (orders_id, orders_products_id, products_options, products_options_values, options_values_price, price_prefix) values ('1', '1', 'download', 'e-book', '0.0000', '+').

I went into mySQL database at Godaddy and looked for the orders_products_attributes table and couldn't find one, so I thought I would import the.

Oscommerce.sql.

File into the database, just in case the orders_products_attributes table didn't get added for some reason.....The oscommerce.sql installed ok but still did not solve the problem. There still is no orders_products_attributes table in the database. Is there suppose to be one, or is one of the other tables perhaps named wrong? I don't know. I am new at this so please forgive the dumb question.

Here is a list of the tables in my SQL store database:.

Address_book.

Address_format.

Administrators.

Adsense_cc.

Amazon_prod.

Banners.

Banners_history.

Cache.

Categories.

Categories_description.

Configuration.

Configuration_group.

Counter.

Counter_history.

Countries.

Currencies.

Customers.

Customers_basket.

Customers_basket_attributes.

Customers_info.

Faq.

Geo_zones.

Info_about.

Info_conditions.

Info_privacy.

Languages.

Links_description.

Links_status.

Links_to_link_categories.

Link_categories.

Link_categories_description.

Manufacturers.

Manufacturers_info.

Newsletters.

Orders.

Orders_products.

Orders_products_download.

Orders_status.

Orders_status_history.

Orders_total.

Products.

Products_attributes.

Products_attributes_download.

Products_description.

Products_notifications.

Products_options.

Products_options_values.

Products_options_values_to_products_options.

Products_to_categories.

Reviews.

Reviews_description.

Seo_google.

Seo_msn.

Seo_yahoo.

Sessions.

Specials.

Tax_class.

Tax_rates.

Whos_online.

Zones.

Zones_to_geo_zones.

Now I have about 200 products in the catalog and would like to add more, if I can get this bug? worked out..

I would greatly appreciate any help you guys can give me. I have been at this for the past week and can't seem to find a solution..

Thanks in advance,.

William..

Comments (9)

Good question... I dunno what is the answer. I'll do some poking around and get back to you if I got an good answer. You should email the people at iPage as they probably could give you help..

Comment #1

Hello Coopco, and thanks for the response..

Yes, the error really does say.

1146 - Table 'mycart.orders_products_attributes' doesn't exist.

("mycart" is the database name)..

This error happens right after I press the button to confirm the order (just before it takes you to the Paypal page).

I installed oscommerce v2.5. It was a pre-built turnkey site, built by a webmaster last year and is suppose to be ready to go.. The install went great with no errors..

This post has been edited by.

William F.

: 07 July 2008, 03:43..

Comment #2

Without knowing the contrib it is hard to get the sql to insert the table correctly. It maybe QTPro from here.

Http://addons.oscommerce.com/info/888..

Comment #3

Hello again Coopco. The contrib is 2.2RC1. Are you saying that I can possibly get this corrected with QTPro for 2.2.RC1?..

Comment #4

You mean QT Pro v4.3 for OSC v2.2 RC1 or osc 2.2RC1?.

Do you have QTPro installed?..

Comment #5

I have this issue only on my admin side, but I didn't install QT Pro. The only module I have installed outside of oscommerce-2.2rc2a is STS. When I go to update the status of an order (using paypal) I get this error message on the admin screen and I cant set the status from pending to processing/shipped..

* Edit: I'm sorry I didnt read the entire error message on this thread before posting. It was close enough, My error message says:.

1146 - Table 'MYCART.orders_status_history_transactions' doesn't exist.

SELECT transaction_id, transaction_type, payment_type, payment_status, module_code, transaction_avs, transaction_cvv2, transaction_msgs FROM orders_status_history_transactions WHERE orders_status_history_id = 1 LIMIT 1.

This post has been edited by.

Mrbags.

: 08 July 2008, 03:21..

Comment #6

OK, I have not used STS, but is there a part of the install that says to do this ?????? if QTPRO is installed?..

Comment #7

No, I don't have QT Pro installed. Should I install version 4.3, and will it work ok with OSC 2.2RC1?.

I would like to mention Coopco that when I installed this version, it came with over 250 products already in the catalog and zip files in the download folder, also with the images of the products in the images folder. When I go into the products attributes section (under catalog), here are the settings:.

Product Options.

Option IDOption Name.

1 |.

ID Option Name Action.

1 Format.

Option Values.

1 |.

ID Option Name Option Value Action.

1 Format Download.

1 |.

ID Product Name Option Name Option Value Value Price Prefix Action.

1 Product 1 Format Download 0.0000 +.

The is NO filename in the filename box for ANY of the products...

There is a dropdown box with all the products in the catalog. Shouldn't they be entered in the filename box as well?(product.zip).

If I enter the filename in the filename box for each product and press insert, won't that give me a different product id then was already added for that product when I installed the script?.

Or, should I just leave things as they are and just put the filename in the box for each product in the dropdown list..

I know this sounds confusing, and I hope you understand what I am asking..

Thanks, William...

Comment #8

Now you are getting to questions that are outside of the boundaries of this forum. Since you have a turnkey solution, you would need to ask the turnkey provider...

Comment #9

I have. The provider says the solution was tested and working fine. I think the prblem is with something that I am doing wrong, which is why I came here...

Comment #10


This question was taken from a support group/message board and re-posted here so others can learn from it.