chrometweaks.org

If a iPage web host crashes, how can you recover the stuff from your site?

Click Here To View All Answers...


First question I got is If a iPage web host crashes, how can you recover the stuff from your site? Thanks in advance for any answer. Second question of mine... Hi again.

When you clink on one of the category links on my web site, you get a column on "n's" appearing on the next page..

See the iPage site www.great-jewelry.net and you'll see what I mean..

Does anyone know what I've done wrong?.

Adrian..

Comments (4)

I would like to know the answer too. Anyone here know what is the right answer to your question. I'll do some poking around and get back to you if I discover an useful answer. You should email the people at iPage as they probably could give you an answer..

Comment #1

ISSUE:.

Display shows the 'n' character in index page when categories are selected..

You have edited the index.php using the online file manager which has removed the \ backslashes from the code, this is a known issue with using the file manager to edit files, it is better to use an ftp program such as ws_ftp to download the file and edit it locally then ftp back to the server..

FIX:.

To fix this issue you will need to find the 4 instances of "n"; on your index.php and change them to "\n";.

Around line #104 look for this code.

While ($categories = tep_db_fetch_array($categories_query)) {.

     $rows++;.

     $cPath_new = tep_get_path($categories['categories_id']);.

     $width = (int)(100 / MAX_DISPLAY_CATEGORIES_PER_ROW)'%';.

     echo '                <td align="center" class="smallText" width="'$width'" valign="top"><a href="'tep_href_link(FILENAME_DEFAULT, $cPath_new)'">'tep_image(DIR_WS_IMAGES$categories['categories_image'], $categories['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)'<br>'$categories['categories_name']'</a></td>'"n";.

     if ((($rows / MAX_DISPLAY_CATEGORIES_PER_ROW) == floor($rows / MAX_DISPLAY_CATEGORIES_PER_ROW)) && ($rows != $number_of_categories)) {.

       echo '              </tr>'"n";.

       echo '              <tr>'"n";.

     }.

   }.

Change to this.

While ($categories = tep_db_fetch_array($categories_query)) {.

     $rows++;.

     $cPath_new = tep_get_path($categories['categories_id']);.

     $width = (int)(100 / MAX_DISPLAY_CATEGORIES_PER_ROW)'%';.

     echo '                <td align="center" class="smallText" width="'$width'" valign="top"><a href="'tep_href_link(FILENAME_DEFAULT, $cPath_new)'">'tep_image(DIR_WS_IMAGES$categories['categories_image'], $categories['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)'<br>'$categories['categories_name']'</a></td>'"\n";.

     if ((($rows / MAX_DISPLAY_CATEGORIES_PER_ROW) == floor($rows / MAX_DISPLAY_CATEGORIES_PER_ROW)) && ($rows != $number_of_categories)) {.

       echo '              </tr>'"\n";.

       echo '              <tr>'"\n";.

     }.

   }.

And then around line #256 look for this code.

While ($filterlist = tep_db_fetch_array($filterlist_query)) {.

         $options[] = array('id' => $filterlist['id'], 'text' => $filterlist['name']);.

       }.

       echo tep_draw_pull_down_menu('filter_id', $options, (isset($HTTP_GET_VARS['filter_id']) ? $HTTP_GET_VARS['filter_id'] : ''), 'onchange="this.form.submit()"');.

       echo '</form></td>'"n";.

     }.

   }.

And change to this.

While ($filterlist = tep_db_fetch_array($filterlist_query)) {.

         $options[] = array('id' => $filterlist['id'], 'text' => $filterlist['name']);.

       }.

       echo tep_draw_pull_down_menu('filter_id', $options, (isset($HTTP_GET_VARS['filter_id']) ? $HTTP_GET_VARS['filter_id'] : ''), 'onchange="this.form.submit()"');.

       echo '</form></td>'"\n";.

     }.

   }..

Comment #2

I'm having a similiar problem, only my characters are Question Marks! My iPage hosting complany moved my iPage site to a new server, cause the old one died and now I have Question Marks at the top of my page and at the bottom!.

Http://www.discountcelebrityphoto.com.

Any help would be appreciated. Ive tried reuploading footer.php, etc// nothings worked so far.

Tammy..

Comment #3

Thanks Steve & John.

That fixed it!!.

What a great forum.

Adrian.

Just one thing. I needed to edit the index.php, but which one is usually needed..

E.g. the html/index.php or even the includes/languages/english/index.php.

In other words, which index.php does what?.

Thanks.

Adrian..

Comment #4

To edit the text on the page it's includes/languages/english/index.php.

Vger..

Comment #5


This question was taken from a support group/message board and re-posted here so others can learn from it.