chrometweaks.org

iPage, Great firewall of china issue?

Click Here To View All Answers...


Quick question... iPage, Great firewall of china issue? Thanks in advance for any answer or 2. My other question... How can I create the database in MySQL?!.

# mysqladmin -u<root> -p<password> create <database_name>.

<root> = Username.

<password>=password.

<database_name> = database Name.

I tried. But not sucessful, why?..

Comments (128)

I would like to know the answer too. Anyone here know what is the right answer to your question. I'll do some investigation and get back to you if I got an anything. You should email the people at iPage as they probably could assist you..

Comment #1

Hi,.

What are the priveledges of the user 'root' ?? Possibly that user does not have the db priv to create ??.

Peter..

Comment #2

When I don't input the password..

It is pass!.

But It show "SQL file does not exist: /install/tchinese.sql".

Why?!.

How can I ?!..

Comment #3

In /var/www/html/catalog/install.

It has the tchinese.sql file..

Is it correct?!.

WHy it say this not exist?!..

Comment #4

Hi,.

For this msg to appear:.

Then possibly you are not running the 'install' from the correct path ??.

From.

Http://wiki.oscommer.../docsInstallNew.

You would just need to point your web browser to:.

/var/www/html/catalog/install.

Which no doubr would translate to:.

Http://localhost/catalog/install.

Peter..

Comment #5

If the "catalog" folder copy to /var/www.

I can't go to the page!!!.

It also be copy in /var/www/html.

Is it?..

Comment #6

What is your server you are using, Host server that is. And secondly what version of PHPMyAdmin are you using? Also make sure you have your permissions set correctly on the install/index.php page.

This post has been edited by.

Paycheck.

: 26 April 2004, 07:24..

Comment #7

I'm using RedHat 8.0 Linux Server.

I don't use PHPmyAdmin software..

So I don't know how to do it...

Comment #8

My default web iPage site path is "/var/www/html".

Then the install oscommerce path is "/var/www/html/catalog/install".

Now it show "the SQL file does not exist: /install/tchinese.sql".

Then, Which path is correct!?..

Comment #9

Hi,.

Possibly you will get us to answer your questions better if you can please tell us:.

1. Where you have the catalog installed ? .

Is it /var/www/html/catalog , or /var/www/html ? .

2. Where does.

Http://localhost.

Point to ? .

Is it /var/www/html , or /var/www ? .

3. Where is the 'install' path located ? .

Is it /var/www/html/catalog/install or /var/www/html/install ? .

Peter..

Comment #10

I discover the "tchinese.sql" file is not the root user permission..

Is it need to change the owner of this file ?!.

How to change ?!.

Thanks~..

Comment #11

I sucessfully change the file owner:.

Chown -c :root tchinese.sql.

But still don't work!.

It also display this error "SQL file does not exist: /install/tchinese.sql".

WHY????..

Comment #12

Hi Toni,.

I notice you are 'bumping' this thread up sometimes with 'smilies'; you might want to read the forum rules:.

Http://forums.oscomm...?act=boardrules.

Peter..

Comment #13

OK~ Sorry~.

But I want to quick to solve this problem!.

Help me OK?!.

Thanks~..

Comment #14

Hi Toni,.

Have you read this -.

Http://wiki.oscommer.../docsInstallNew.

To ensure that all your paths are defined correctly. It simply sounds like a path problem, because you do have the SQL file in the 'install' path, yet the installation must be looking somewhere else, because it gives the error msg..

Edit:.

.. especially the 'Step 4' part..

Peter.

This post has been edited by.

Peterr.

: 26 April 2004, 10:07..

Comment #15

I copy the "Install" folder to ./.

It is sucessfully to install..

But in next page, it show:.

Warning: fopen("/var/www/html\includes/configure.php", "w") - 沒有此一檔案或目錄 in /var/www/html/catalog/install/templates/pages/install_7.php on line 209.

Warning: fputs(): supplied argument is not a valid File-Handle resource in /var/www/html/catalog/install/templates/pages/install_7.php on line 210.

Warning: fclose(): supplied argument is not a valid File-Handle resource in /var/www/html/catalog/install/templates/pages/install_7.php on line 211.

Warning: fopen("/var/www/html\admin/includes/configure.php", "w") - 沒有此一檔案或目錄 in /var/www/html/catalog/install/templates/pages/install_7.php on line 259.

Warning: fputs(): supplied argument is not a valid File-Handle resource in /var/www/html/catalog/install/templates/pages/install_7.php on line 260.

Warning: fclose(): supplied argument is not a valid File-Handle resource in /var/www/html/catalog/install/templates/pages/install_7.php on line 261..

Comment #16

Toni,.

Someone had a similar problem, see:.

Http://forums.oscommerce.com/index.php?sho...10&#entry355142.

Peter..

Comment #17

Thanks~.

But I also don't know how to fix it... =.=!..

Comment #18

You can try chmod the two configure.php files 777 all rights to all things or manually configure the two files or delete the two files admin/includes/configure.php and catalog/includes/configure.php..

Comment #19

Hi Toni,.

I found lots of posts with the same error messages, try this:.

Http://forums.oscommerce.com/index.php?act...dle+%2Bresource.

But maybe first, if you can tell me what a phpinfo() tells you what DOCUMENT_ROOT value is please..

Peter..

Comment #20

Hi,.

Okay, so going by what your other posts have stated:.

'catalog' = /var/www/html/catalog/.

'install' = /var/www/html/catalog/install/.

To do the install, you would simply need to use:.

Http://localhost/catalog/install.

In your browser..

Can you please post your.

Catalog/includes/configure.php.

, but remove the db name, username and password of course..

Also, you could try what Steve suggested:.

Try Steve's suggestions in the order above..

1. cmod the 2 configure.pph files to 777, then try the install again.

2. Manually edit the 2 configure.php files to ensure the paths are correct, then try the install again..

3. Delete both the configure.php files, and try the install again. I think why Steve has suggested this step, is because , if you tick one of the check boxes in the install, both the configure.php files are 'rebuilt' for you..

Peter..

Comment #21

But now I can't start the Apache Server..

When I type:.

[root@linux /] # /etc/rc.d/init.d/httpd start.

Then it show:.

啟動 httpd:Syntax error on line 283 of /etc/httpd/conf/httpd.conf:.

Error: Apache has not been designed to serve pages while.

Running as root. There are known race confidions that.

Will allow any local user to read any file on the system..

If you still desire to serve pages as root then.

Add -DBIG_SECURITY_HOLE to the CFLAGS env variable.

And then rebuild the server..

It is strongly suggested that you instead modify the User.

Directive in your httpd.conf file to list a non-root.

User..

How can I solve ?!.

Thx~..

Comment #22

Toni,.

This sort of problem may not be (easily) answered in the osC forums. If you don't get assistance here for any Apache problems, try a good webmasters iPage site like "Sitepoint", the Apache forums are.

Here.

..

Peter..

Comment #23

OH~ but this forum said I have no permission to post question...

Comment #24

Toni,.

Just register as a new user, I have found Sitepoint very helpful in many areas. Basically, if other forums can't answer the question, I always get the solution at Sitepoint..

Peter..

Comment #25

How can I create the database in MySQL?!.

# mysqladmin -u<root> -p<password> create <database_name>.

<root> = Username.

<password>=password.

<database_name> = database Name.

I tried. But not sucessful, why?..

Comment #26

It show:.

Access denied for user: 'root@localhost' (Using password: YES).

WHY?!.

WHat's matter?!..

Comment #27


This question was taken from a support group/message board and re-posted here so others can learn from it.