chrometweaks.org

iPage vs 1&1 for small to median web store, best service & price?

Click Here To View All Answers...


My first question is iPage vs 1&1 for small to median web store, best service & price? Many thanks for any comment. 2nd question I got is.. I tried to change the html_output function page to allow Flash .swf files to be displayed as written.

Here.

I notice that this seems to have been written back at version 1.1.1.1.

I am using 2.2 MS2..

I get these errors..

Parse error: parse error in /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/html_output.php on line 74.

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/html_output.php:74) in /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/sessions.php on line 67.

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/html_output.php:74) in /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/sessions.php on line 67.

Fatal error: Call to undefined function: tep_image() in /home/syndica/public_html/jeremy/WEB/catalog/includes/header.php on line 57.

The basic idea of the code seems to be if the file has the .swf extension then embed as a flash file. It does not seem to proper Flash you need the object AND embed tags like this:.

(I'm not sure how the height and width parameters should be handled as they would change depending where the image is used.).

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000".

Codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0".

WIDTH="100" HEIGHT="100" id="movie1" ALIGN="">.

<PARAM NAME=movie VALUE="myFlash.swf"> <PARAM NAME=quality VALUE=high> <PARAM NAME=bgcolor VALUE=#FFFFFF> <EMBED src="myFlash.swf" quality=high bgcolor=#FFFFFF WIDTH="100" HEIGHT="100" NAME="movie1" ALIGN="".

TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED>.

</OBJECT>.

If anyone has nailed this mod I would really like to know..

This has to be done for the admin html_output.php page as well..

I can go through my iPage site and manually insert the flash code around the existing code.

On a page by page basis - but this is tedious. (this also confines me to .swf - I want to be able to use gifs and jpgs too).

I don't know PHP well enough to know what I'm doing yet..

Maybe someone sells this mod for a price if it is not freely available?.

Maybe there are complexities in the code that would not allow such a global procedure?.

Any help appreciated!.

Jeremy..

Comments (68)

That's a good question. I'm not sure what is the answer to your question. I'll do some research in Google and get back to you if I got an answer. You should email the people at iPage as they probably could assist you..

Comment #1

Thanks for the contribution..

I followed the instructions on a clean install of MS2.(no other contribs yet).

I tried the admin version of the mod (for the html_output page in admin) and it gave the same errors..

Any idea why it doesn't work for me?.

Should I be worried about the version of PHP running on my server.

Not supporting this new code?.

Jeremy..

Comment #2

99% of the time this:.

Mean that you have an extra line after the last ?> at the bottom of the file, in this case html_output.php or sessions.php.

The_Bear..

Comment #3

Thanks for that tip, I checked for extra line after last ?> and fixed, but still get errors..

When I installed I selected to save session info in the database as I am on shared hosting..

I wonder if this could be causing the session_start() errors?.

(the store worked fine before - so maybe this is not an issue).

Jeremy..

Comment #4

Try changing this line,.

To call the actual location of the file. If the file is in.

Http://www.yoursite/flash.

Then try to change it to <EMBED src="http://www.yoursite/flash/myFlash.swf" I hope that works for you. I had a similar error. If that does not help, email me and I will test it for you again...

Comment #5

Thanks for the absolute vs relative url suggestion, but I don't think it's the problem because the file is not directly called in this code - just the object that represents the images is called. I just put up the Flash embed code from Macromedia because I thought this contribution should somehow include the object tag with the activex classid code in addition to the existing '<embed src="' for Mac/Windows compatibility, but this doesn't really have anything to do with the problem (i don't think:) of the session_start() warnings and the fatal error (posted above) where tep_image() is said to be defined (though presumably it already was - name didn't change).

I used the code that Chris posted.

Here.

..

It's a two page post. I tried replacing just the html image wrapper part as in the first part of the post. Right below that is a version for the admin. I tried that also. (neither worked) Then I tried.

The entire page version at the end of the post (pg2) which I figured would eliminate any possible.

Errors I might be introducing. That didn't work either. Maybe you could try that full page version.

And see if it works for you..

The PHP version on my shared iPage hosting is 4.2.3 if that can be of any help..

I could just "manually" insert the Flash code into individual pages which I have done with success, but the solution that Chris has offered is much more efficient. The best part is the logic which allows the use of gifs and Flash and gets it all done in one place. (html_output.php) Just wish I could get it to work:-).

Thanks.

Jeremy..

Comment #6

I tried to change the html_output function page to allow Flash .swf files to be displayed as written.

Here.

I notice that this seems to have been written back at version 1.1.1.1.

I am using 2.2 MS2..

I get these errors..

Parse error: parse error in /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/html_output.php on line 74.

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/html_output.php:74) in /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/sessions.php on line 67.

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/html_output.php:74) in /home/syndica/public_html/jeremy/WEB/catalog/includes/functions/sessions.php on line 67.

Fatal error: Call to undefined function: tep_image() in /home/syndica/public_html/jeremy/WEB/catalog/includes/header.php on line 57.

The basic idea of the code seems to be if the file has the .swf extension then embed as a flash file. It does not seem to proper Flash you need the object AND embed tags like this:.

(I'm not sure how the height and width parameters should be handled as they would change depending where the image is used.).

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000".

Codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0".

WIDTH="100" HEIGHT="100" id="movie1" ALIGN="">.

<PARAM NAME=movie VALUE="myFlash.swf"> <PARAM NAME=quality VALUE=high> <PARAM NAME=bgcolor VALUE=#FFFFFF> <EMBED src="myFlash.swf" quality=high bgcolor=#FFFFFF WIDTH="100" HEIGHT="100" NAME="movie1" ALIGN="".

TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED>.

</OBJECT>.

If anyone has nailed this mod I would really like to know..

This has to be done for the admin html_output.php page as well..

I can go through my iPage site and manually insert the flash code around the existing code.

On a page by page basis - but this is tedious. (this also confines me to .swf - I want to be able to use gifs and jpgs too).

I don't know PHP well enough to know what I'm doing yet..

Maybe someone sells this mod for a price if it is not freely available?.

Maybe there are complexities in the code that would not allow such a global procedure?.

Any help appreciated!.

Jeremy..

Comment #7

Actually, I wrote that, and I did so on an MS2 install..

-Chris..

Comment #8


This question was taken from a support group/message board and re-posted here so others can learn from it.