chrometweaks.org

iPage will not transfer my domains. What now?

Click Here To View All Answers...


Got a quick question: iPage will not transfer my domains. What now? Thanks in advance for any answer. Another quick question... 1) Where and how do I place my image file (my logo) at the top - the header - so it'll be on all (or most) of the pages like on the OS Sample? AND I want my logo to be used as a link??? How do I do this? Please help ... and thanks..

2) Should I delete the OS Commerce footer? I think so. How is this done? Where is the file located to do this? Like where is footer.php located? In which folder?.

3) Where can I edit the word Manufacturer that is throughout? I want to change word Manufacturer to Artist..

The answers to these questions will help me feel like I'm making progress. I have already added categories and products, descriptions and image files. That part was amazing and really shows things progressing. But this whole thing has to work! And my fingers are crossed..

Is there a good tutorial which teaches about editing the pages and WHERE the pages that need to be edited are located?.

4) Do we have to show the three languages options (icons) or can we just show English only? How would I delete the other two icons ... for my purposes it seems like they are a distraction!?.

5) Is the Admin tool secure? Is there a special way to secure this?.

I know there's lots more I need to know ... this is a start..

Thank you for any and all help..

C...

Comments (168)

Hmm... I need to find out myself. I don't know what is the right answer. I'll do some research and get back to you if I discover an good answer. You should email the people at iPage as they probably can answer it..

Comment #1

I attempted to follow the instructions on the Link Logo to Another Site..

I tried typing in this information (below) but I don't think this is the way to replace the OS Comemrce logo ... or is it? Plus, is there a quick way to determine exactly which is line 84? or whatever number?.

THE ERROR MSG I GOT:.

Parse error: parse error, unexpected T_STRING in C:\webspace\mdscorp\cathylynn\cathy-lynn.com\www\catalog1\includes\languages\english.php on line 84.

Parse error: parse error, unexpected ':', expecting ',' or ';' in C:\webspace\mdscorp\cathylynn\cathy-lynn.com\www\catalog1\includes\header.php on line 57.

WHAT am I doing wrong? Help?.

LINK LOGO TO ANOTHER iPage site (these directions I thought I followed).

In header.php change:.

<td valign="middle"><?php echo tep_image(DIR_WS_IMAGES'oscommerce.gif', 'OSCommerce'); ?></td>.

TO:.

<td valign="middle"><?php echo '<a href="'HEADER_IMAGE_LINK'">'tep_image(DIR_WS_IMAGESHEADER_IMG_PIC, HEADER_IMG_ALT)'</a>'; ?></td>.

I wonder if I put my info in correctly?.

Then in english.php define the following: (I didn't see anything like this to edit, so I just typed this in near the top with my relevant information.).

//define header image information.

Define('HEADER_IMG_PIC', 'yourimage.gif');.

Define('HEADER_IMG_ALT', ' Welcome to whatever you want here ');.

Define('HEADER_IMAGE_LINK','http://www.example.com'); [this will open your page up in the same window].

Define('HEADER_IMAGE_LINK','http://www.example.com" target="_blank'); [this will open your page in another browser].

The definitions make it easier for future changes to image and link and alt for the logo...

Comment #2

Change:.

<td valign="middle"><?php echo tep_image(DIR_WS_IMAGES'oscommerce.gif', 'OSCommerce'); ?></td>.

To:.

<td valign="middle"><?php echo tep_image(DIR_WS_IMAGES'yourimage.gif', 'Welcome to whatever you want here'); ?></td>.

Don't forget to put your logo in the images directory...

Comment #3

//define header image information.

Define('HEADER_IMG_PIC', 'yourimage.gif');.

Define('HEADER_IMG_ALT', ' Welcome to whatever you want here ');.

Define('HEADER_IMAGE_LINK','http://www.example.com'); [this will open your page up in the same window].

Define('HEADER_IMAGE_LINK','http://www.example.com" target="_blank'); [this will open your page in another browser].

The definitions make it easier for future changes to image and link and alt for the logo..

Remove:.

[this will open your page up in the same window].

[this will open your page in another browser].

The definitions make it easier for future changes to image and link and alt for the logo..

This post has been edited by.

Yesudo.com.

: 07 March 2004, 15:52..

Comment #4

I hope you can continue to help??.

Does this look like I'm doing it right?.

TEXT FOR HEADER.PHP (Is this correct?).

<td valign="middle"><?php echo '<a href="'HEADER_IMAGE_LINK'">'tep_image(DIR_WS_IMAGES'G5-masthead.jpg''</a>'; ?></td>.

TEXT FOR ENGLISH.PHP (Where does the following go?).

//define header image information.

Define ('HEADER_IMG_PIC', 'G5-masthead.jpg');.

Define ('HEADER_IMG_ALT', 'Welcome to Gallery Five');.

Define ('HEADER_IMAGE_LINK', 'http://gallery5.com"target="_blank');..

Comment #5

Does this work or what error messages do you have:.

Try:.

<td valign="middle"><?php echo '<a href="'HEADER_IMAGE_LINK'">'tep_image(DIR_WS_IMAGESHEADER_IMG_PIC, HEADER_IMG_ALT)'</a>'; ?></td>.

And then in english.php you have:.

//define header image information.

Define('HEADER_IMG_PIC', 'G5-masthead.jpg');.

Define('HEADER_IMG_ALT', 'Welcome to Gallery Five');.

Define ('HEADER_IMAGE_LINK', 'http://gallery5.com" target="_blank');.

This post has been edited by.

Yesudo.com.

: 07 March 2004, 16:40..

Comment #6

Hi there my name is Simon and I have been following the discussion closley as I too have the same problem. I have replaced the codes in the correct places that you have told me but I now have an error coming up on the front page of my shop. I have enclosed the error code please you take alook at it..

Parse error: parse error in /var/www/html/oscommerce/includes/languages/english.php on line 83.

I went to line 83 but there is nothin there related to what I added.

1 is there somewhere spasiffic that you are sopposed to put the code in english.php?.

2 Can anyone think of what I may be doing wrong..

Comment #7

Check the spaces in the code. That was one of my problems...

Comment #8

Shouldn't think that that would be a problem as took the code sfrom the last entry in the thead!..

Comment #9

Some editors remove the \ before ' in your text..

I think What's New is near that line change to What\'s New..

Also in the file you may have some lines like:.

Please select a payment method for your order.\n'.

But the \ before the n in your file may have been removed. Add it back in..

This post has been edited by.

Yesudo.com.

: 08 March 2004, 12:53..

Comment #10

YesUdo.com helped me resolve the problem ... thank you again..

By using this code below AND removing the code in the english did it for me, so good luck!.

<td valign="middle"><?php echo '<a href="website url goes here".

Target="_blank">'tep_image(DIR_WS_IMAGES'image file goes here')'</a>'; ?></td>..

Comment #11

I will try that but where am I supposed to put the section of code:-.

//define header image.

Does it make a difference where this is placed in the english.php code?.

The only place that I have edited the files, is online? I have taken a look at that section you mentioned but when I changed everything back to the way it was before, it works fine and the code aoround there reads what's new.

How will changing it to what/'s new make a difference when I add in the extra code?..

Comment #12

I don't think I can be much more of a help ... I am too new at this...

Comment #13

Thanks for trying,.

I have got a little further using your method no errors any more but will have to wait to see if anyone else has any ideas. Thanks..

Comment #14

Some editors remove the \ before ' in your text..

I think What's New is near that line change to What\'s New..

Also in the file you may have some lines like:.

Please select a payment method for your order.\n'.

But the \ before the n in your file may have been removed. Add it back in..

Try a different editor...

Comment #15

Got it thanks! that has all worked now at least I have a logo on the page...

Comment #16

1) Where and how do I place my image file (my logo) at the top - the header - so it'll be on all (or most) of the pages like on the OS Sample? AND I want my logo to be used as a link??? How do I do this? Please help ... and thanks..

2) Should I delete the OS Commerce footer? I think so. How is this done? Where is the file located to do this? Like where is footer.php located? In which folder?.

3) Where can I edit the word Manufacturer that is throughout? I want to change word Manufacturer to Artist..

The answers to these questions will help me feel like I'm making progress. I have already added categories and products, descriptions and image files. That part was amazing and really shows things progressing. But this whole thing has to work! And my fingers are crossed..

Is there a good tutorial which teaches about editing the pages and WHERE the pages that need to be edited are located?.

4) Do we have to show the three languages options (icons) or can we just show English only? How would I delete the other two icons ... for my purposes it seems like they are a distraction!?.

5) Is the Admin tool secure? Is there a special way to secure this?.

I know there's lots more I need to know ... this is a start..

Thank you for any and all help..

C...

Comment #17

What am I doing wrong? I have been reading the info on Wiki, but I haven't been able to find the files that I want to open and make changes to??? Help please..

Should I be in the File Manager?..

Comment #18


This question was taken from a support group/message board and re-posted here so others can learn from it.