chrometweaks.org

My iPage website is not working. what should I do?

Click Here To View All Answers...


My first question is My iPage website is not working. what should I do? Thanks in advance for any comment. Second question of mine... I don't know what the blazes it is that I am doing wrong but nothing I try seems to let me install oscommerce. I have tried following the directions but nothing works. All I get is a file not found error.

Will someone please guide me to the proper instructions before I go more insane that I already feel like I am??.

Thanks,.

Charms..

Comments (163)

That's a good question. I'm not sure what is the answer to that question. I'll do some Googling and get back to you if I find an good answer. You should email the people at iPage as they probably can help you..

Comment #1

Followoing the new installation instructions, I:.

(a) uploaded the catalog directory to my document root folder.

(.

Created the database using the tools provided by my webhosting service and made note of the names, etc..

© opened my web browser.

(d) typed in.

Http://myserver/catalog/install.

Didn't work.

(e) tried.

Http://myserver/cata...install/install.

Which also didn't work.

(f) tried every other possible combination of (d) and/or (e) also with no results..

Now what?.

Charms..

Comment #2

Try "http://myserver/catalog/install/index.

This post has been edited by.

Fbrace.

: 06 March 2009, 16:09..

Comment #3

On your server there is a directory called 'public_html' (or similar).

You must upload all files there, so when you look with ftp you have public_html/catalog etc etc..

Comment #4

1. uploaded files to my public_html directory. Sorry I forgot to mention that. Tried combinations inserting that also in the appropriate place as well..

2. just tried "http://myserver/catalog/install/index" and had not luck. Still a not found message..

Next suggestion or tip please...

Comment #5

And can you see the files there with ftp?..

Comment #6

Yes I see that the files are there using both filezilla and the file manager utility my iPage hosting service provides...

Comment #7

When you look in the catalog directory do you see the likes if index.php..

Comment #8

Yes. there is a file by that name in the catalog folder.

Is that the one I need?..

Comment #9

The you enter.

Www.mydomain.com/catalog.

The browser will load that automatically, assuming it's the only index file there..

You did upload the entire distribution?.

Are you entering your url correctly?.

Are your nameservers pointing your iPage domain name to your server..

Comment #10

I reloaded all of it and I feel like I lost ground instead of gained. I am going to leave it for a while and come back. maybe it will make more sense in a couple of hours...

Comment #11

A simple test for you, copy the following into a emty file and save it as index.html, then upload that to the root of your iPage site (public_html) then put in your iPage domain name, if you don`t see the message your not looking at your web space..

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">.

<html>.

<head>.

<title>HOME PAGE TEST</title>.

</head>.

<body>.

<font size="large">THIS IS MY HOME PAGE<br />.

<br />.

If I see nothing I`m not looking in the right place!!!!</font>.

</body>.

</html>..

Comment #12

Hi Sam. I know my webpage works because it is up right now but without the shopping cart I need to put on it. I swear, I have never had so much trouble with something in all my life! I am going tolet it reast for the weekend and start back with it on Monday...

Comment #13

Hi out there. I am back again for at least a little while. The last time I tried to install os, tghis is the last error message I got:.

Internal Server Error.

The server encountered an internal error or misconfiguration and was unable to complete your request..

Please contact the server administrator, Port 80.

Any suggestions on what it is I need to do?.

Charms..

Comment #14

Have you checked that php & sql are both available on your server, if so what versions are they?..

Comment #15

MySQL is version 4.1.22 and as for php, I know it is there but the only thing I can find is phpMyAdmin version 2.11.9.4. I do know that php is available on the server because I can find where it lists a number of modules that are installed. Does this info help you?..

Comment #16

Copy this into an empty file, save as test.php & upload to your root, open the file in your browser, what do you get?.

<?php.

Phpinfo();.

?>..

Comment #17

Hi....i had this kind of problems too.....and I can't found out what's the problems at all....i had try to create the index.html and I saw the words but test.php I saw the error 404 - files or directory not found again.

Here is the picture.......

Anyone know how to fix this problems plz help me....thanks..

Comment #18

Perhaps check with your webhost and find out if you have php..

Comment #19

Hi Coopco...the iPage hosting support php 4 and 5........

Comment #20

Hi....is php4 and I can switch to php if require........

Comment #21

And...did php run as CGI or FastCGI ? .

Thanks..

Comment #22

Switch to php5.

You must have copied the test.php to the wrong place if you got the 404 error...

Comment #23

Hi......is working after I change to php5 but there are an error , under PHP Extensions - it show OpenSSL with a red cross.....what is that mean ? and how to solve it ? .

Thanks..

Comment #24

I found where my control panel tells what php extension and applications are installed and the list is pretty big. it also shows what version it all is. the ones I think apply to this problem are DB version 1.7.13, DB_DataObject version 1.8.8 and DB_NestedSet version 1.4.ORC1. I couldn't get your little code you gave me last night to work by the way...

Comment #25

Hi...

May I know what is database server ? when executing the install there have a field to insert that......

Thanks..

Comment #26

Is done....i had everything insert in the fields and finish the installation but when I click on the catalog button is show "file not found" again.

At the web server section I put.

Web Server.

Default value for WWW Address :.

Http://www.teleporttravel.comd:\inetp...2;catalog\.

Then I change to.

WWW Address :.

Http://www.mysite.com.

Default value Webserver Root Directory : D:/inetpub/vhosts/teleporttravel.com/httpdocs/catalog/.

Then I change to.

Webserver Root Directory : wwwroot.

Is that correct ?

Comment #27

It would appear then that you do not have php installed, talk to your host, or as the sql you mentioned is old, perhaps find a new better host...

Comment #28

Sam, customer service for my iPage hosting company says the PHP version 5.4.6. As for switching to a different service, I can't afford to do that...

Comment #29

Hey, Sam; I finally got someone from customer service to help me out. I have osc installed now. Just want to say thanks for everything..

Charms..

Comment #30

Hey Cheryl,.

Any idea what your host had to correct for you??? It might be helpful to others in the future, as I have watched you go around with this for sometime. OSC has never been that hard to setup and configure for me on two seperate occasions, an original setup, then an update. I guess the third is pending anyday now with v3.0.

Fred..

Comment #31

My php is 5.2.6 and Mysql is MySQL client version: 5.0.22.

Till now I still canot solve it.....WTH........

Comment #32

I don't know what the blazes it is that I am doing wrong but nothing I try seems to let me install oscommerce. I have tried following the directions but nothing works. All I get is a file not found error. I am about ready to tear my hair out over this as I had the same problem when I tried to use zen-cart. Will someone please guide me to the proper instructions before I go more insane that I already feel like I am??.

Thanks,.

Charms..

Comment #33

Write down.

Step by step.

, what you are doing, then someone will say were your going wrong...

Comment #34


This question was taken from a support group/message board and re-posted here so others can learn from it.