chrometweaks.org

Server iPage hosting service providers with WordPress ; fully functional condition without errors.?

Click Here To View All Answers...


My first question is Server iPage hosting service providers with WordPress ; fully functional condition without errors.? Thanks for any response. Another question I got... I can't get my shopping cart from delivery address to payment method I've selected a shipping type, and a delivery address, but when I click next, it takes me back to the delivery address page..

Looking at the browser status, it tries to load checkout_payment.php, but then seems to redirect back to checkout_address.php..

Looking closer at the address, it says checkout_payment.php?PHPSES....

At that point it gets cut off by my browsers status display size..

I'm currently set up to only accept payments through PayPal..

If I load up the admin tool and look at payment options it says:.

Installed Payment Modules: paypal.php.

Allow PayPal: 1.

PayPal ID:.

Credit Card TP email address: NONE.

What is Credit Card TP email address? Do I need it? Any help is greatly apreciated, thank you...

Comments (257)

Hmm... I need to find out myself. I don't know what is the right answer to your question. I'll do some research and get back to you if I got an anything. You should email the people at iPage as they probably could help you..

Comment #1

Here's the form code for that page:.

<form name="checkout_address" method="post" action="<? echo tep_href_link(FILENAME_CHECKOUT_PAYMENT, '', 'SSL'); ?>">.

I notice the 'SSL'. I don't have any type of secure server currently. Could this be what's throwing it off? Is there a way to turn that section off, or do I have to invest in a secure certificate such as verisign? Is there perhaps a cheaper option (preferrably free) instead of verisign?..

Comment #2

Check your catalog/includes/configure.php file to ensure that Enable SSL is set for False..

You will never be able to get a free SSL cert. The cheapest you can get is $50US from.

InstantSSL.

...

Comment #3

Still no go on the next page button. Sure enough SSL was enabled, I disabled it, and still nothing. I tried changing SSL in the form action to NONSSL, and that didn't work either..

For the life of me, I can't figure out why I can't get to the next page. It's almost as if it's a redirector. It says it's loading the payment options page, but then it changes it's mind and says it's loading the delivery address page..

I wouldn't figure it would be an error in either page though, they set that up to work, and I think they'd probably have noticed that when you click next on the delivery page it redirects you back to the delivery page. There has to be something in my config file that's messed up..

Still, if anyone has a clue as to what it might be, I'd apreciate a general nudge in the right direction. Thanks...

Comment #4

All of the checkout pages have statements near their tops that will redirect if the information from the previous page is not entered..

Therefore, if the checkout_payments.php page does not detect a shipping address then it will redirect back to the shipping page which sounds like exactly what you are encountering..

The only thing left for me to suggest is to look through the checkout_payment.php page to find all of the checks/redirects and then test to see that the information is getting from checkout_shipping.php. Obviously one of the checks is failing and it is just a matter of determining which one..

Be sure to clear your cache and temporary files and then retry after disabling SSL. That may still be hanging around somewhere. :?..

Comment #5

I commented out the reason it wouldn't let me into the payment page, now when I get there I get the following:.

Shipping Carrier Select Preferred Rate.

United Parcel Service UPS Unsupported country specified $5.00USD.

Unsupported country specified? How on earth do I fix that? I'm asuming something with the admin tool, but I can't find anything...

Comment #6

That is probably due to the shipping address not being present..

Edit your catalog/includes/functions/general.php file and add:.

// void tep_debug_var (string form, string varname).

// dumps the value of the variable passed to it..

Function tep_debug_var ($where, $var='') {.

 if (!empty($where)) {.

 echo "<p>debug $where: ";.

 if (is_object($var) || is_array($var)) {.

   echo "<br />n<pre>n";.

   print_r($var);.

   echo "n</pre></p>";.

   reset($var);.

 } else {.

   echo "$var</p>";.

 }.

 }.

}.

And then edit your catalog/checkout_payment.php file and after:.

 require('includes/application_top.php');.

Add:.

Tep_debug_var('checkout_payment.php:post', $_POST);.

Tep_debug_var('checkout_payment.php:session', $_SESSION);.

Exit;.

And that will display the contents of the post and session variables so you can see what is there and what is missing...

Comment #7

Ok, I put in the debug script, and this is what I get:.

Debug checkout_payment.php:post:.

Array.

(.

).

Debug checkout_payment.php:session:.

Array.

(.

[cart] => shoppingcart Object.

(.

[contents] => Array.

(.

[22] => Array.

(.

[qty] => 1.

).

).

[total] => 89.99.

[weight] => 7.

).

[language] => english.

[currency] => USD.

[customer_id] => 1.

).

It doesn't really mean much to me, does it tell you anything?..

Comment #8

For some reason your shipping information is not getting added to your session..

Remove the 2 tep_debug_var lines from your checkout_payment.php file and add them to your checkout_shipping.php file after (around line 88) the lines:.

// process the selected shipping method.

 if ( isset($HTTP_POST_VARS['action']) && ($HTTP_POST_VARS['action'] == 'process') ) {.

Making the whole thing look like:.

// process the selected shipping method.

 if ( isset($HTTP_POST_VARS['action']) && ($HTTP_POST_VARS['action'] == 'process') ) {.

Tep_debug_var('checkout_payment.php:post', $_POST);.

Tep_debug_var('checkout_payment.php:session', $_SESSION);.

Exit;.

And let me know what you get after you click the continue button on the checkout_shipping page...

Comment #9

Here's a suggestion, sometimes parts of osCommerce act a little strange when the server is running an older version of PHP. For instance, I had problems with accounts being created, but the users could not log in. It kept redirecting them back to default catalog page and the span still said "guest.".

I struggled with this problem for about a month, then I upgraded the PHP on my server to version 4.3.2 and it solved all the strange happenings..

It's just a shot in the dark, but maybe you should check your PHP version and upgrade to a newer version...

Comment #10

I looked in the catalog directory... and there's no checkout_shipping.php. Could this be the problem, and if so, what do I do?..

Comment #11

It looks like I am having a similar problem to this. I got down to the part where it says my address isn't making it to the session. I could not find the file or the remaining instructions on how to fix this problem. Please help. I keep getting redirected to the address page from the payment page. I have tried deleting all of the tax codes and zones, etc as previously suggested...

Comment #12

I can't get my shopping cart from delivery address to payment method I've selected a shipping type, and a delivery address, but when I click next, it takes me back to the delivery address page..

Looking at the browser status, it tries to load checkout_payment.php, but then seems to redirect back to checkout_address.php..

Looking closer at the address, it says checkout_payment.php?PHPSES....

At that point it gets cut off by my browsers status display size..

I'm currently set up to only accept payments through PayPal..

If I load up the admin tool and look at payment options it says:.

Installed Payment Modules: paypal.php.

Allow PayPal: 1.

PayPal ID:.

Credit Card TP email address: NONE.

What is Credit Card TP email address? Do I need it? Any help is greatly apreciated, thank you...

Comment #13

I had/have same prolemo :-P There's an extra page in there that needs to be taken off the chain of events..

When checking out, at the shipping address page, it seems the purchaser has to click on the [CHANGE ADDRESS] before the purchaser can proceed/continue to the next [PAYMENT METHOD] page...

Comment #14


This question was taken from a support group/message board and re-posted here so others can learn from it.