chrometweaks.org

What are the populations of the first 10 iPage in the world?

Click Here To View All Answers...


First question I have is What are the populations of the first 10 iPage in the world? Looking forward for any comment. 2nd question I got is.. Hi all,.

I've searched the posts and haven't found the *exact* solution to my problem so here it is: I am setting up an osC iPage site on GoDaddy. We purchased an SSL cert for the domain. I notice that now when I try to access the iPage site via FTP the IP address has changed. No problem, I can still log in and upload. However, my store is not secure. I've never used a cert from GoDaddy so I'm not sure of the settings in configure.php..

I've tried some things suggested here, but nothing works. Here's my configure.php code:.

Define('HTTP_SERVER', 'http://www.thefatasserie.com');.

Define('HTTPS_SERVER', 'https://www.thefatasserie.com');.

Define('ENABLE_SSL', true);.

Define('HTTP_COOKIE_DOMAIN', 'thefatasserie.com');.

Define('HTTPS_COOKIE_DOMAIN', 'thefatasserie.com');.

Define('HTTP_COOKIE_PATH', '/');.

Define('HTTPS_COOKIE_PATH', '/');.

Define('DIR_WS_HTTP_CATALOG', '/');.

Define('DIR_WS_HTTPS_CATALOG', '/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

Define('DIR_FS_CATALOG', 'z:/home/128osc/www/');.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

The store is up and seems to be running okay. I'm able to add/delete products, etc. I just don't know what more I need to do to secure it. BTW, GODaddy support couldn't give me any help. Thanks for any insight...

Comments (8)

Good question... I dunno what is the answer to that question. I'll do some Googling and get back to you if I got an answer. You should email the people at iPage as they probably can answer it..

Comment #1

Hi Jack,.

I did that, but no change. The pages are still unsecured. One question, should that period before the "www" be there? In any case, it's currently not working..

Mike..

Comment #2

Yes, the period should be there. You should also make the same change to.

Define('HTTP_COOKIE_DOMAIN', 'thefatasserie.com');.

The problem is probably how godaddy is using to mark a page as secure. See.

This.

Thread and use the test code there to find the proper code for your shop..

Jack..

Comment #3

SSL is installed..

Your code is not using href standard coding practie needed for oscommerce..

Else Your My account would have pointed to.

Https://thefatasserie.com/login.php.

But is pointing to.

Http://thefatasserie.com/login.php.

You need to modify those links..

Probably You purchased a template that used a direct href rather tep href function of oscommerce..

Satish..

Comment #4

Thanks, Satish. Where do I go to modify them?..

Comment #5

Well You need to FTP into Your iPage site and chek for the code that results in the link..

It appears it's in footer..

So in includes>>footer.php.

Satish..

Comment #6

Well I don't think I needed to do anything with the footer, however, after some tinkering (thanks, Jack) I seem to have gotten it to work. My checkout process is now secure..

I did not need the initial periods before the iPage domain name (as is given in that SSL example post), but merely the iPage domain itself (in my case 'thefatasserie.com')..

I also noticed that I had the default setting still on this line: define('DIR_FS_CATALOG', 'z:/home/128osc/www/');.

Which is what it was set to in the template I am using. I *think* that got changed during installation, but I may have uploaded an old version. In any case, it's working. Now on to the admin section....

Thanks Jack, thanks Satish. I am grateful for your help...

Comment #7

You will need the period for the session ID's to be removed from the url's so that should be changed..

Jack..

Comment #8

Jack,.

Thanks again. I didn't realize that, but now I know. I re-added those periods...

Comment #9


This question was taken from a support group/message board and re-posted here so others can learn from it.