chrometweaks.org

What happend to iPage site? I could not open my site www.iPage.com/elango?

Click Here To View All Answers...


My first question is What happend to iPage site? I could not open my site www.iPage.com/elango? Thanks for any response. Second question of mine... Hi there, I'm having a little problem with my SSL certificate setup on my site. Basically the certificate seems to work fine, but I get the "this iPage site contains both secure and non-secure items" problem. Trouble is it isn't just on the odd page, it's that all of the images and styles are linked with "http", and when you click don't show secure items all that shows is a rough layout with no images, text or styles. Also when I click on any link it takes me back to http:, rather than https..

This is my /includes/configure.php file contents (sensitive info has been hashed out):.

<?php.

Define('HTTP_SERVER', 'http://www.halfpriceteak.co.uk');.

Define('HTTPS_SERVER', 'https://www.halfpriceteak.co.uk');.

Define('ENABLE_SSL', true);.

Define('HTTP_COOKIE_DOMAIN', 'www.halfpriceteak.co.uk');.

Define('HTTPS_COOKIE_DOMAIN', 'www.halfpriceteak.co.uk');.

Define('HTTP_COOKIE_PATH', '/');.

Define('HTTPS_COOKIE_PATH', '/');.

Define('DIR_WS_HTTP_CATALOG', '/');.

Define('DIR_WS_HTTPS_CATALOG', '/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

Define('DIR_FS_CATALOG', '#####/halfpriceteakshop/');.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

Define('DB_SERVER', '#####');.

Define('DB_SERVER_USERNAME', '#####');.

Define('DB_SERVER_PASSWORD', '#####');.

Define('DB_DATABASE', '#####');.

Define('USE_PCONNECT', 'false');.

Define('STORE_SESSIONS', 'mysql');.

?>.

This iPage site is at.

Https://www.halfpriceteak.co.uk/.

If anyone has any ideas I'd be very grateful, thanks in advance.

...

Comments (118)

I would like to know the answer too. Anyone here know what is the answer to that question. I'll do some poking around and get back to you if I discover an good answer. You should email the people at iPage as they probably could answer your iPage question..

Comment #1

Thank you.

After reading that link, it seems to be a iPage hosting problem (for future reference I use servage, so people can change this safely for this host)..

I had to edit /includes/application_top.php and change:.

// set the type of request (secure or not).

$request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';.

To:.

// set the type of request (secure or not).

$request_type = (getenv('HTTPS') == '1') ? 'SSL' : 'NONSSL';.

Again, thanks to germ for helping out with this one.

This post has been edited by.

Aberry9036.

: 22 March 2009, 19:18..

Comment #2

Damn... actually that hasn't worked, the reason I thought it had was that I'd changed the settings in servage so that it automatically switched to ssl from http, but actually it was still referencing unsecure items..

I have tried all those fixes but none have helped... does anyone have any other ideas?..

Comment #3

Copy the text in the CODE box below into a text editor (Notepad) on your PC:.

<?php.

Echo 'HTTP HOST: '"$HTTP_HOST";.

Echo '<br>Server Port: 'getenv('SERVER_PORT');.

Echo '<br>SSL Status: 'getenv('HTTPS');.

Echo '<br>Fowarded Server: 'getenv('HTTP_X_FORWARDED_SERVER');.

Echo '<br>Fowarded Host: 'getenv('HTTP_X_FORWARDED_HOST');.

Echo '<br>Fowarded By: 'getenv('HTTP_X_FORWARDED_BY');.

?>.

Save it as.

Myenv.php.

Upload it into your root folder on your server..

When you've done this post again...

Comment #4

Https://www.halfpric...co.uk/myenv.php.

Posts.

HTTP HOST:.

Server Port: 80.

SSL Status:.

Fowarded Server: www.halfpriceteak.co.uk.

Fowarded Host: www.halfpriceteak.co.uk.

Fowarded By:..

Comment #5

You've got a redirect going on somewhere..

When I try to access the script via.

Http.

It changes to.

Http.

S.

I can't help until you shut that off...

Comment #6

Ok.. give me a bit of time to do so, it will take half an hour or more for the redirect to stop (crappy iPage hosting service) thanks for your help so far.

This post has been edited by.

Aberry9036.

: 22 March 2009, 20:10..

Comment #7

OK..

When the redirect stops, I'll see what gives and have another suggestion..

I've helped a lot of people with this problem and we almost always find a solution...

Comment #8

Ok, so that is taking far too long, so I've put myenv.php in a seperate virtual host at shop.halfpriceteak.co.uk/myenv.php. This should have all the same settings as www.halfpriceteak.co.uk.

It posts.

HTTP HOST:.

Server Port: 80.

SSL Status:.

Fowarded Server:.

Fowarded Host:.

Fowarded By:.

I also might note (because, apart from the first, I don't know if they make a difference) that PHP safe mode is off, php safe mode gid is on, and php register globals is off...

Comment #9

OK.

What does it say if you access it with a.

Http.

S.

URL?..

Comment #10

The redirect is switched off now so I'll post them both;.

With http it posts:.

HTTP HOST:.

Server Port: 80.

SSL Status:.

Fowarded Server: www.halfpriceteak.co.uk.

Fowarded Host: www.halfpriceteak.co.uk.

Fowarded By:.

And ssl it posts:.

HTTP HOST:.

Server Port: 80.

SSL Status:.

Fowarded Server: www.halfpriceteak.co.uk.

Fowarded Host: www.halfpriceteak.co.uk.

Fowarded By:.

Although, if you meant "forwarded server" means there's a forward in place, I don't know why that's coming up.... that is quite odd o.o..

Comment #11

Hi there, I'm having a little problem with my SSL certificate setup on my site. Basically the certificate seems to work fine, but I get the "this iPage site contains both secure and non-secure items" problem. Trouble is it isn't just on the odd page, it's that all of the images and styles are linked with "http", and when you click don't show secure items all that shows is a rough layout with no images, text or styles. Also when I click on any link it takes me back to http:, rather than https..

This is my /includes/configure.php file contents (sensitive info has been hashed out):.

<?php.

Define('HTTP_SERVER', 'http://www.halfpriceteak.co.uk');.

Define('HTTPS_SERVER', 'https://www.halfpriceteak.co.uk');.

Define('ENABLE_SSL', true);.

Define('HTTP_COOKIE_DOMAIN', 'www.halfpriceteak.co.uk');.

Define('HTTPS_COOKIE_DOMAIN', 'www.halfpriceteak.co.uk');.

Define('HTTP_COOKIE_PATH', '/');.

Define('HTTPS_COOKIE_PATH', '/');.

Define('DIR_WS_HTTP_CATALOG', '/');.

Define('DIR_WS_HTTPS_CATALOG', '/');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

Define('DIR_FS_CATALOG', '#####/halfpriceteakshop/');.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

Define('DB_SERVER', '#####');.

Define('DB_SERVER_USERNAME', '#####');.

Define('DB_SERVER_PASSWORD', '#####');.

Define('DB_DATABASE', '#####');.

Define('USE_PCONNECT', 'false');.

Define('STORE_SESSIONS', 'mysql');.

?>.

This iPage site is at.

Https://www.halfpriceteak.co.uk/.

If anyone has any ideas I'd be very grateful, thanks in advance.

...

Comment #12

OsC isn't pickup up the cue from the server that SSL is "on"..

Some things you can try here:.

Click me..

Comment #13


This question was taken from a support group/message board and re-posted here so others can learn from it.