chrometweaks.org

What happens after I register with iPage.com?

Click Here To View All Answers...


My 1st question is: What happens after I register with iPage.com? Thanks in advance for any answer. Another question... Here the problem when I what to send in e-mail out to my Customers like for Newsletter Manager and Send Email To Customers. It will not send to them. But when they put in a order in it send me the order e-mail..

Can anyone help me out with Problem?..

Comments (131)

I would like to know the answer too. Anyone here know what is the right answer. I'll do some investigation and get back to you if I got an decent answer. You should email the people at iPage as they probably could answer your iPage question..

Comment #1

I Try sending mail through the "contact us" link but nothing go out what going on with this mail set up??..

Comment #2

With me the email works in Contact. I'm just not getting feedback when I sign up for a new account..

Double-check the email address that you entered in the Admin panel...

Comment #3

There are a few problems with the e-mail smtp on a windows box I have found and there are many posts about it als some bug reports..

This cannot contain spaces I think this is the line for e-mail.php in catalog includes classes e-mainl.php.

If (EMAIL_TRANSPORT == 'smtp') {.

Return mail($to_addr, $subject, $this->output, 'From: '$from$this->lf'To: '$to$this->lfimplode($this->lf, $this->headers)$this->lfimplode($this->lf, $xtra_headers));.

} else {.

Return mail($to, $subject, $this->output, 'From: '.$from.$this->lf.implode($this->lf, $this->headers).$this->lf.implode($this->lf, $xtra_headers));.

}.

}.

I also think it's the same in admin includes classes e_mail.php.

So replace this code in admin and catalog with the above..

Its on line 499 or so.

Also at the bottom of catalog>includes>functions>general.php.

These lines need to look like this.

// nl2br() prior PHP 4.2.0 did not convert linefeeds on all OSs (it only converted \n).

Function tep_convert_linefeeds($from, $to, $string) {.

#if ((PHP_VERSION < "4.0.5") && is_array($from)) {.

Return ereg_replace('('implode('|', $from)')', $to, $string);.

} #else {.

#return str_replace($from, $to, $string);.

#}.

#}.

Hope that solves the e-mail issues for you..

Comment #4

Hey guys I might have a solution to your problem. If you look in the admin section under configuration there email options. In you have the choice to put sendmail or SMTP. Since I have my own server I use SMTP. Depending on what and who is iPage hosting your iPage site you might need to email and ask them to give you there SMTP...

Comment #5

I already have the correct setting in Admin - sendmail..

When I send myself a test message from the Contact form, it works. But I didn't get an acknowledgement that I created a new account...

Comment #6

I have a Linux server and I set the email options Transport: Sendmail.

Linefeed: LF and still not working at all...

Comment #7

I talke to my web server Host and they say that I need to use mail.DomainName.com for both pop and smtp..

Where can I change this at?..

Comment #8

Did you check the admin panel where you set the smtp? I don't use that option so I don't know if lets you type in that information there or not...

Comment #9

Yes I check the admin panel I have 2 option smtp and sendmail only no type in area...

Comment #10

I need help set up my mail on osCommerce 2.2 Milestone 2. My host Support say that I need to set The sendmail path as /use/sbin/sendmail. How can I do this?..

Comment #11

That's an excellent question. This should be in the admin panel somewhere but I didn't see it either..

I usually set it in the script but am not sure where. I don't know if it's required with PHP but probably is..

And, yet, my Contact form is working without my putting in the sendmail information. Strange..

Maybe someone knows the answer? If I find out, I'll let you know...

Comment #12

I just did a search and found this. This might help:.

Http://forums.oscommerce.com/index.php?sho...=0&#entry337197..

Comment #13

I look at that forum and I look at my table here what I have for my E-mail set..

INSERT INTO `configuration_group` VALUES (12, 'E-Mail Options', 'General setting for E-Mail transport and HTML E-Mails', 12, 1);..

Comment #14

Here's another post that might help:.

Http://forums.oscommerce.com/index.php?sho...10&#entry337124.

Messing around with PHP code makes me nervous though...

Comment #15

I have read that form and try all of that to. I search yesterday for my Error I m have but nothing I try work for my...

Comment #16

Try this contribution. Just might do the trick..

SMTP Authentication..

Comment #17

In your admin panel, go to Configuration, and under My Store, go to 'Send extra order e-mails to', and input your e-mail address there. Whenever a customer makes an order you'll receive an exact copy of the e-mail that they receive from you..

Under e-mail options, make sure that the 'Send e-mails' option is set to true..

I have never known osCommerce to send an e-mail just because a customer registers with your site, only when they actually make an order from your site..

If I'm wrong on this last point then perhaps someone who knows better will enlighten us all..

Hope this helps - Vger..

Comment #18

Ok thank you for that now how about the EXTRA ORDER EMAILS. Do I still receive my order e-mail and othere e-mail..

Comment #19

When 'Send extra order e-mails' is enabled you will receive a copy of the same e-mail the customer receives when they make an order - so you will know straightaway that they have made an order, and what it is that they have ordered..

Vger..

Comment #20

With the contribution you must leave the Extra Order Email section blank..

You will receive all normal emails and be able to send emails. Just check your admin page for orders...

Comment #21

Ok on my web iPage site side anyone signed up for a new account, and the "Contact us" link wood it still work with that and will my Customers still get there order e-mail?..

Comment #22

I still like to know why the original e-mail set up isn't working for my...

Comment #23

No way to connect to your iPage domain email account. With this contribution you enter your.

Smtp.domain.xxx, your user name and password, it then uses your email account...

Comment #24

Here what my host said that I need to use.

The sendmail path as /use/sbin/sendmail.

Or.

Mail.mydomainname.com.

And if this help here my server info.

Database Host: localhost (127.0.0.1).

Server OS: Linux 2.4.20-28.7 Database: MySQL 3.23.56.

Server Date: 04/18/2004 11:40:35 Datebase Date: 04/18/2004 11:40:35.

Server Up Time: 11:40am up 77 days, 21:18, 1 user, load average: 0.47, 0.46, 0.40.

HTTP Server: Apache/1.3.27 (Unix) (Red-Hat/Linux) FrontPage/5.0.2.2623 mod_python/2.7.8 Python/1.5.2 mod_ssl/2.8.12 OpenSSL/0.9.6b DAV/1.0.2 PHP/4.1.2 mod_perl/1.26.

PHP Version: 4.1.2 (Zend: 1.1.1)..

Comment #25

If your host said to use sendmail, do NOT use this contribution. It is for SMTP only..

Check your catalog/admin/includes/classes/email.php see if it matches catalog/includes/classes/email.php. If not copy catalog/includes/classes/email.php and replace catalog/admin/includes/classes/email.php..

This post has been edited by.

Fl70.

: 18 April 2004, 20:13..

Comment #26

I have read this forum.

Http://forums.oscommerce.com/index.php?showtopic=24963&st;=10.

And I test using this.

<?.

Mail(",", "My Subject", "Line 1\nLine 2\nLine 3");.

?>.

And I didn't receive any e-mail with that..

And my catalog/admin/includes/classes/email.php and my catalog/includes/classes/email.php there the same...

Comment #27

You used your email address..

<?.

Mail("you@yourdomain.xxx,", "My Subject", "Line 1\nLine 2\nLine 3");.

?>..

Comment #28

I'm having a similar issue. ALL my emails are going out (order notices, order status notices, new account creations, contact us), BUT when I try to email my customers nothing happens??? (I'm on my own Linux box)..

I tried to send a newsletter too, but I'm not real sure how to use the Newsletter Manager. It has a big red X under sent and all I can seem to do is Preview or Lock the Newsletter. How do you send or delete a Newsletter?..

Comment #29

To send a Newsletter select send email in admin, select 'To All Newsletter Subscribes" in the 'to' box..

To delete a newsletter select Newsletter Manager in admin and delete or create a newsletter there...

Comment #30

Got it. I didn't realize you had to Lock it before you can send/delete/edit..

Seems to be working fine now. Thanks...

Comment #31

I have use my email address an I have nothing it been like 10 min no e-mail..

Here what the.

<? phpinfo(); ?>.

Code show me about the mail.

Sendmail_from.



Sendmail_path.

/usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i.

Short_open_tag.

On On.

SMTP.

Localhost localhost..

Comment #32

In admin under Configuration/Send E-mail from try ' '..

Can't hurt at this point...

Comment #33

That don't work nothing I try work..

Why this code don't work?.

<?.

Mail("you@yourdomain.xxx,", "My Subject", "Line 1\nLine 2\nLine 3");.

?>.

This post has been edited by.

Tom knight.

: 18 April 2004, 21:17..

Comment #34

What other code can I use to test the server e-mail or other code like the OSCommerce2.2 use right?..

Comment #35

Can I just take out there e-mail code set up and add my othere mail code to it?..

Comment #36

Thank you all for help me out. I have fix the error I was have with my e-mail it was the host the said that it was me but it was them all the time..

They said that they never see the error before I was update you all about this...

Comment #37

Here the problem when I what to send in e-mail out to my Customers like for Newsletter Manager and Send Email To Customers. It will not send to them. But when they put in a order in it send me the order e-mail..

Can anyone help me out with Problem?..

Comment #38

I think I might have the same problem. When I signed up for a new account, I never received the notification..

I'll be interested to see what the answers are for you..

Sorry that I can't help at the moment...

Comment #39


This question was taken from a support group/message board and re-posted here so others can learn from it.