chrometweaks.org

What is the best java web iPage hosting service in the USA?

Click Here To View All Answers...


My first question is What is the best java web iPage hosting service in the USA? Thanks for any answer. My other question... I'm using osc 2.2ms2 with authorizenet..

I've been struggling with this since my iPage site went live 3 weeks ago. I've been tweaking and tweaking, tried everything I could think of regarding sessions, got a certificate hoping that it would resolve itself, but to my surprise I found 7 more credit card customers who have the following problem:.

After shopping, entering their credit card into, and confirmng their orders, they get popped back to.

Checkout_payment.php.

Instead of.

Checkout_success.php.

A few get popped back to.

Login.php.

(fewer have the latter as I think it may have been a sessions issue with my shared cert. I've since installed my own)..

What happens next is something terrible. Their cards get authorized (without them realizing it) and their items remain in their cart. So what would any unsuspecting customer do? Try it again. So they do! You can already imagine the nightmare. Some customers have 3 or four authorizations go through until it denies and then they get confused, frustrated and now I have a situation..

On top of it, no order gets generated in OSC. So I have to log in as them, empty their cart using FAX/PHONE or MONEY ORDER methods, and then call them to get the number to their banks so that they can release the unnecessary authorizations..

It's quite a nightmare as I spent 2 hours fixing the 7 orders I discovered today..

Has anyone ever encountered this, or knows what could possible be causing the problem? I blame it on cookies each time, but that won't fly for too much longer. My cart should be able to handle this, right? I know there is something I'm missing..

Sorry for having to ask this here, but I've search various terms and came up empty handed with solutions. I've tried to fix it myself, but there are still these few that slip through. It's quite embarrassing. Also, like I said, this only happens to about 10% of my customers, which is why I'm so damned confused. 90% sail through without any problems!.

KEPA..

Comments (217)

Good question... I dunno what is the answer to your question. I'll do some research and get back to you if I find an decent answer. You should email the people at iPage as they probably could assist you..

Comment #1

Nope, not that, I've looked everywhere and the order is always in customers_basket until you check them out, then it gets recorded in orders...

Kepa..

Comment #2

An interesting observation kepa..

I have orders sitting in my customer_basket table. And NO order information elsewhere..

This morning I received a payment notification from paypal, but found no order information in my admin panel. This is a new customer, new order..

Per this post, I checked my customer_basket, and have discovered what I believe is the basket contents as they should have been copied over to the orders table..

Unfortunately, my problem is not yet resolved because I have to figure out the shipping method selected by the customer. (I am offering UPS and USPS).

....

Also, should there be any records in the customer_basket once a transaction is completed? Some of the records date back 4 months..

This post has been edited by.

Dangeo1.

: 07 December 2003, 12:54..

Comment #3

I'm having this identical problem..

However, we're running test orders through and consistently PayPal works okay, but authorize.net payments fail in this very way.

There is one PayPal failure reported above - are others seeing it in PayPal or Authorize.net or others? Lets try to narrow it down. What is the payment method selected?.

(The behavior is : orders not moved to order table, credit card is charged, order is still in shopping cart, customer is returned to login screen - and incidently - his first attempt to re-login will always fail - not FAIL, but just refresh to the login screen, when they can login okay)..

This is serious. I'm about to revert back to an HTML store unless some intelligent, experienced forum member has some great insight..

I'm also having a USPS shipping problem (apparently) and I see this reported in other threads. But just in case they are related, 90% of attempts to checkout (go to shipping screen with USPS ) gets and "this page cannot be displayed.".

The appearance of that problem is keeping them from ever seeing the credit card problem (and I'm loosing business!).

Thanks...

Comment #4

I hope there is an answer here before I go live this week. I also will be using Authorize.net.

Thanks,.

Scott90SC..

Comment #5

Question as I am reading through this iPage site I have noticed that alot of these type problems are relate to Ipowerweb are any of you iPage hosting with them?.

Scott90SC..

Comment #6

Yes, I use IPowerWeb...

There is another forum topic/ thread talking about the SHIPPING screen problem reported uniquely by iPowerWeb users:.

Http://forums.oscomm...showtopic=68622.

I have given iPowerWeb lots of info on that issue. As of yet, I don't have enough specifics on this issue to feed to iPowerWeb...

Comment #7

I am not using IPowerWeb..

The problem, as it pertains to me, I suspect is due to user error, or poor flow through the checkout process..

I use only paypal to process payments..

When a customer returns to my space after entering their payment information into paypal, they *should* click "continue" until they receive "SUCCESS"..

Failure to continue once returning from paypal causes the transaction to be incomplete. Funds are received, but no order records are written... the only place I can see any order information is by checking the customer_basket. And, from there I have to figure their order, guess at shipping details, and manually generate invoices and packing slips..

The "work around" for my problem is using the paypal IPN (instant payment notification). I am still investigating the impact of using this modification on my system. It is supposed to detect when a payment is made and automatically complete the transaction so that records don't get lost in the mix...

Comment #8

Does any one resolve this problem yet? Everytime somedy buy from me outside of the US. I receive their payment in paypal but I didn't get any comfirmation or no records in the admin.. Why is that?..

Comment #9

Has this been resolved? I am having similar problems. Customers are getting bounced back to the index page asking them to log in, the orders are not in their carts any longer, and nowhere in the admin..

I don't know what to check in the db to see if the orders are being recorded. What table records the order items?.

The cards are being charged though, but I have no record of any orders being placed. I am using SSL, and all seems to be working, but I still have to check the db. So far, at first glance, I don't see anything in the database. I'm thinking the programmer I had install OSC, may have messed up the database somehow..

Anyone know what tables to look at? Unfortunately, it's a live site. All seemed to be working well until I installed the Secure Pay module, but I never really tested as I thought the programmer did this... but apparently didn't....

Thanks.....

Comment #10

I'm using osc 2.2ms2 with authorizenet..

I've been struggling with this since my iPage site went live 3 weeks ago. I've been tweaking and tweaking, tried everything I could think of regarding sessions, got a certificate hoping that it would resolve itself, but to my surprise I found 7 more credit card customers who have the following problem:.

After shopping, entering their credit card into, and confirmng their orders, they get popped back to.

Checkout_payment.php.

Instead of.

Checkout_success.php.

A few get popped back to.

Login.php.

(fewer have the latter as I think it may have been a sessions issue with my shared cert. I've since installed my own)..

What happens next is something terrible. Their cards get authorized (without them realizing it) and their items remain in their cart. So what would any unsuspecting customer do? Try it again. So they do! You can already imagine the nightmare. Some customers have 3 or four authorizations go through until it denies and then they get confused, frustrated and now I have a situation..

On top of it, no order gets generated in OSC. So I have to log in as them, empty their cart using FAX/PHONE or MONEY ORDER methods, and then call them to get the number to their banks so that they can release the unnecessary authorizations..

It's quite a nightmare as I spent 2 hours fixing the 7 orders I discovered today..

Has anyone ever encountered this, or knows what could possible be causing the problem? I blame it on cookies each time, but that won't fly for too much longer. My cart should be able to handle this, right? I know there is something I'm missing..

Sorry for having to ask this here, but I've search various terms and came up empty handed with solutions. I've tried to fix it myself, but there are still these few that slip through. It's quite embarrassing. Also, like I said, this only happens to about 10% of my customers, which is why I'm so damned confused. 90% sail through without any problems!.

KEPA..

Comment #11

Try to query db,orders table and see if the orders are there.If you can't see the orders in admin you can force osc to show up by order no.Hidden orders seem to be everywhere in these threads...

Comment #12


This question was taken from a support group/message board and re-posted here so others can learn from it.