chrometweaks.org

What is the maximum capacty of a page on my homepage on yahoo iPage?

Click Here To View All Answers...


First of all What is the maximum capacty of a page on my homepage on yahoo iPage? Many thanks for any response. My 2nd question... I just installed the Shopping cart and When I launch the store I get this error: Warning: I am able to write to the configuration file: /home/by/public/viv/includes/configure.php. This is a potential security risk - please set the right user permissions on this file..

I have CHMODed the file to 644 but it still gives me this error, why and how do I fix this?.

When I launch the admin panel I get this error: FATAL ERROR: register_globals is disabled in php.ini, please enable it!.

Not sure why as I have the php.ini in root and th store works fine except for the write error issue on the top of the page..

Thank you for your help..

Rob.

This post has been edited by.

Rob_illinois.

: 04 November 2008, 23:36..

Comments (88)

Good question... I dunno what is the answer to your question. I'll do some research in Google and get back to you if I discover an anything. You should email the people at iPage as they probably can help you..

Comment #1

Ok, will do. I did try 444 and same error. it is really weird..

The iPage site is a template iPage site I got so it has a template with it. Is it easy to upgrade after I install this version or is there a way to install the new version and then just plugin the template I have with this all in one package?.

Thanks.

This post has been edited by.

Rob_illinois.

: 05 November 2008, 00:20..

Comment #2

It isn't a simple process to update to the latest version - RC2a. You have to go through a process of all the 2.2 updates to 060817, then the update to RC1 and finally RC2..

All the updates are included within the latest package - a text file to update 060817 and a Diff page for the RC1/RC2 changes - but you need a spare afternoon to go through it..

The problem with a template is some pull the code around a bit. So, some of the changes might not be as obvious - maybe!.

Some hosts setup their servers so you can't change permission levels via FTP. Go to your iPage hosting control panel and try to change permissions to 444 from there. If that still doesn't work, ask your host to do it for you...

Comment #3

Ok thanks I will go through the documents and see when I have time to do the update..

I can get to the store now but get this error for the admin panel:.

Fatal error: Cannot re-assign $this in /home/by/public_html/viv/Store/admin/includes/classes/upload.php on line 31.

Ideas?..

Comment #4

Yeah, that is an indication of how old your template files are. This update takes care of that problem, along with a lot of others..

Http://www.oscommerc...e-20051113.html..

Comment #5

Yeah I have osCommerce 2.2-MS2.

Also get this error for the FAQ's.

Warning: require(includes/languages/english/FILENAME_FAQS) [function.require]: failed to open stream: No such file or directory in /home/by/public_html/viv/Store/faqs.php on line 15.

Fatal error: require() [function.require]: Failed opening required 'includes/languages/english/FILENAME_FAQS' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/by/public_html/viv/Store/faqs.php on line 15.

Line 15 is:.

Require(DIR_WS_LANGUAGES$language'/'FILENAME_FAQS);..

Comment #6

All root level files have a corresponding language file. The file includes/languages/english/faq.php is missing so you need to upload it...

Comment #7

I uploaded the faqs.php file and still same error. Arghhh..

Comment #8

I just installed the Shopping cart and When I launch the store I get this error: Warning: I am able to write to the configuration file: /home/by/public/viv/includes/configure.php. This is a potential security risk - please set the right user permissions on this file..

I have CHMODed the file to 644 but it still gives me this error, why and how do I fix this?.

When I launch the admin panel I get this error: FATAL ERROR: register_globals is disabled in php.ini, please enable it!.

Not sure why as I have the php.ini in root and th store works fine except for the write error issue on the top of the page..

Thank you for your help..

Rob.

This post has been edited by.

Rob_illinois.

: 04 November 2008, 23:36..

Comment #9

Download the latest version of osCommerce from the Solutions link above and register_globals off wont be an issue. If 644 doesn't work, try 444...

Comment #10


This question was taken from a support group/message board and re-posted here so others can learn from it.