chrometweaks.org

When I try to get on some websites iPage.com comes up?

Click Here To View All Answers...


Got a quick question: When I try to get on some websites iPage.com comes up? Many thanks for any answer. Another question on my mind: I have a problem with my checkout pages, every time I try to go to my account or hit the checkout button I get a 404 page not found error..

I have restored every one of my database backups with the same results..

Does any body have any tips on where I should start looking?..

Comments (58)

I'm stumped. I'm not so sure what is the answer to that question. I'll do some research in Google and get back to you if I got an useful answer. You should email the people at iPage as they probably can help you..

Comment #1

I am able to pull the iPage site up thru https, still can't open the checkout pages or the account pages..

This is my configure.php.

<?php.

/*.

$Id: configure.php,v 1.13 2003/02/10 22:30:51 hpdl Exp $.

OsCommerce, Open Source E-Commerce Solutions.

Http://www.oscommerce.com.

Copyright © 2003 osCommerce.

Released under the GNU General Public License.

*/.

// Define the webserver and path parameters.

// * DIR_FS_* = Filesystem directories (local/physical).

// * DIR_WS_* = Webserver directories (virtual/URL).

Define('HTTP_SERVER', ''); // eg,.

Http://localhost.

- should not be empty for productive servers.

Define('HTTPS_SERVER', ''); // eg,.

Https://localhost.

- should not be empty for productive servers.

Define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

Define('DIR_WS_CATALOG', '/catalog/'); // absolute path required.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG'pub/');.

Define('DIR_FS_DOCUMENT_ROOT', $HTTP_SERVER_VARS['DOCUMENT_ROOT']); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs).

Define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOTDIR_WS_CATALOG);.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

// define our database connection.

Define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers.

Define('DB_SERVER_USERNAME', 'mysql');.

Define('DB_SERVER_PASSWORD', '');.

Define('DB_DATABASE', 'osCommerce');.

Define('USE_PCONNECT', 'false'); // use persistent connections?.

Define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'.

?>..

Comment #2

According to your Configure file, you don't have your iPage site enabled with SSL at all. you need to fill these places out before you can have it enabled.

Define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers.

Define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers.

Define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

This is what mine looks like, however you need to put your own info and not literally copy mine.

Define('HTTP_SERVER', 'http://babysweet.net'); // eg, http://localhost - should not be empty for productive servers.

 define('HTTPS_SERVER', 'https://host108.ipowerweb.com/~babyswee'); // eg, https://localhost - should not be empty for productive servers.

 define('ENABLE_SSL', true); // secure webserver for checkout procedure?..

Comment #3

That is what I thought, I am under a shared ssl thru my host does that make a difference? Also the odd thing is that it was working up until yetserday..

Comment #4

Shared SSL certificate is okay, you just need to know your host's server that your files reside on, (i.e. host108.ipowerweb.com as seen above)...

Comment #5

I have a problem with my checkout pages, every time I try to go to my account or hit the checkout button I get a 404 page not found error..

I have restored every one of my database backups with the same results..

Does any body have any tips on where I should start looking?..

Comment #6

You should be double checking your configure.php files for the proper setting for your ssl setup, possibly not pointing to the right spot..

Comment #7


This question was taken from a support group/message board and re-posted here so others can learn from it.