chrometweaks.org

Where do sites like iPage and network solutions get their domains from?

Click Here To View All Answers...


Got a question... Where do sites like iPage and network solutions get their domains from? Thanks for any comment. Second question.. This forum is "Suggestions" so I'll post my little bug here....

/admin/orders.php.

When you are in the Admin site, and you click the "Customers" and then "Orders" it opens the following url:.

/admin/orders.php.

Which properly shows ALL orders... great..

Now the problem is when you drop down the "Status" menu to filter down no only Pending (1), processing (2), or delivered (3) (all of which work perfectly) and then SELECT "All Orders"... this is where it breaks... it opens:.

/admin/orders.php?status=.

And, it cannot display all entries where status = '' because all orders have a status of 1, 2 or 3....

Change the URL action for "All Orders" to only "orders.php" without any query string..

Clifford Wagner..

PS, if there is somewhere official "BUGS" are to be posted... let me know...

Comments (48)

Good question... I dunno what is the right answer to your question. I'll do some research and get back to you if I bump into an useful answer. You should email the people at iPage as they probably can help you..

Comment #1

BTW, even thought the URL shows admin/orders.php?status=, this doesn't break my admin, though, because if that value is false, it automatically displays all orders...

Comment #2

Btw, when reporting bugs, please search the previous bugs to see if it has been reported already. For example, this one was posted as bug 1340..

Hth,.

Matt..

Comment #3

In our store I fixed this as follows:.

In /catalog/admin/orders.php.

Approx line 357.

Change.

Elseif (isset($HTTP_GET_VARS['status'])) {.

To.

Elseif (isset($HTTP_GET_VARS['status']).

&& tep_not_null($HTTP_GET_VARS['status']).

) {.

Cheers.

Rob..

Comment #4

This forum is "Suggestions" so I'll post my little bug here....

/admin/orders.php.

When you are in the Admin site, and you click the "Customers" and then "Orders" it opens the following url:.

/admin/orders.php.

Which properly shows ALL orders... great..

Now the problem is when you drop down the "Status" menu to filter down no only Pending (1), processing (2), or delivered (3) (all of which work perfectly) and then SELECT "All Orders"... this is where it breaks... it opens:.

/admin/orders.php?status=.

And, it cannot display all entries where status = '' because all orders have a status of 1, 2 or 3....

Change the URL action for "All Orders" to only "orders.php" without any query string..

Clifford Wagner..

PS, if there is somewhere official "BUGS" are to be posted... let me know...

Comment #5

There is a bug reporter on the main osCommerce site, under "Community":.

Http://www.oscommerc.../community/bugs..

Comment #6


This question was taken from a support group/message board and re-posted here so others can learn from it.