chrometweaks.org

Where I can gat a free web iPage hosting service and domain name for my web.?

Click Here To View All Answers...


My 1st question is: Where I can gat a free web iPage hosting service and domain name for my web.? Looking forward for any comment. Second question.. Ok, everything works fine when I use Mozilla, but in IE there is a couple problems..

1- A customer can log in, but then if they go to click on any other link in the store it logs them out then loads that linked page..

2- Like the first problem... when I add an item to the shopping cart and then click on a link in the store to go see more products the item in the cart dissapears..

If you need any more info just tell me and I'll get it..

Ive had several customers tell about this problem which has lost a few orders for me..

Comments (157)

Good question... I dunno what is the answer to your question. I'll do some investigation and get back to you if I find an decent answer. You should email the people at iPage as they probably can answer it..

Comment #1

I've got this sorted out now. Perhaps the solution will be the same for you..

Because I use htaccess to redirect users from mydomain.com to mydomain.com/catalog/, when a user clicked 'Home' (which directed to mydomain.com), they were considered logged out..

I commented out this line in /catalog/includes/application_top.php:.

//  $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);.

Changed the catalog language define in english.php to:.

Define('HEADER_TITLE_CATALOG', 'Home');.

And changed the 'Home' link in my footer to direct to /catalog/ as well..

Problem solved..

Now if you have the issue when a user clicks product pages as well (I didn't), then you may have to do some investigating...

Comment #2

Oh forgot about your 1st problem ... are they AOL users or ..?.

Your 'Sessions' settings in Admin > Configuration > My Store should look like:.

Session Directory /tmp  .

Force Cookie Use False  .

Check SSL Session ID False  .

Check User Agent False  .

Check IP Address False  .

Prevent Spider Sessions True  .

Recreate Session False  ..

Comment #3

Ok I tried both suggestions you had and the problem is still there..

No they are not AOL users, it happens to anyone using IE, but it seems to work fine when I test it with Mozilla...

Comment #4

Ok I think I figured out why it does it, but I'm not sure how to fix it..

My store is located at www.mysite.com/home.

I have another iPage domain (www.myothersite.com) that I have a url frame directing to the store.

When I use www.myothersite.com the problems occur, but when I just directly use the url of www.mysite.com/home it seems to work fine..

Hopefully this makes sense.

Any ideas on how to make it work? or do I just have to use the direct url to the site..

Thanks..

Comment #5

Ok for now I just am using URL forwarding, but I would really like to use URL Frame, oh well I guess I will live. Thanks for your help..

Comment #6

If the customer ever visits a link containing www.myothersite.com, the problem will occur. I'm not sure how you would configure it so that either could be used...

Comment #7

Ok, everything works fine when I use Mozilla, but in IE there is a couple problems..

1- A customer can log in, but then if they go to click on any other link in the store it logs them out then loads that linked page..

2- Like the first problem... when I add an item to the shopping cart and then click on a link in the store to go see more products the item in the cart dissapears..

If you need any more info just tell me and I'll get it..

Ive had several customers tell about this problem which has lost a few orders for me..

Comment #8

I've got issue 2 as well, just started happening. I'm using MSIE 6 for testing. Something to do with cookie/session settings I'd imagine...

Comment #9


This question was taken from a support group/message board and re-posted here so others can learn from it.