chrometweaks.org

Which webhosting is better iPage.com or lunarpages.com?

Click Here To View All Answers...


Got a quick question: Which webhosting is better iPage.com or lunarpages.com? Looking forward for any response. My other question... Okay, I've searched through this whole system for a solution. I've tried them all it seems. None have done it..

I want to use cookies. I don't want these long session ID's in my URL because engines are not indexing ANY of my other pages. But I keep getting the cookie_usage.php when I try to add anything to my cart. So does everyone else..

The three settings that pertain to this - what do I set them to?.

Prevent Spider Sessions - True?.

Force Cookies - True?.

Safe Url - True?.

I don't know. Also, I've messed around with my configure.php in my includes directory. Here are the settings I have right now:.

Define('HTTP_SERVER', 'http://www.bptparts.com');.

Define('HTTP_CATALOG_SERVER', 'http://www.bptparts.com');.

Define('HTTPS_CATALOG_SERVER', '');.

Define('HTTP_COOKIE_DOMAIN', 'www.bptparts.com');.

Define('HTTPS_COOKIE_DOMAIN', '');.

Define('HTTP_COOKIE_PATH', '/');.

Define('HTTPS_COOKIE_PATH', '/');.

Do I set the cookie path to /public_html/ or /www/? Do I set the iPage domain to www.bptparts.com or bptparts.com? Does any of this really affect what I'm trying to do?.

I KNOW that there is a way to do this, I've seen some osCommerce sites doing it effectively. I would really appreciate seeing a final answer to this problem if ANYONE has one. It seems like everyone is asking this same question again and again...

Comments (118)

Good question... I dunno what is the right answer. I'll do some poking around and get back to you if I bump into an useful answer. You should email the people at iPage as they probably could help you..

Comment #1

Most posters will be on the forum within the next five hours so a solution may take some time...

Comment #2

The only setting that really matters here is 'Force Cookie Usage'. You hsould also have Prevent Spider Sessions set to true, and Search Engine Safe Urls set to False, but these last two really have no bearing on your problem..

If you have 'Force Cookie Usage' set to True, then the only time you get the cookie_usage.php is if your browser does not accept cookies...

Comment #3

The only thing is, I wish this were true, at least in my case..

I've tried it. I made sure my browser settings were correct. I've sent the link to friends to try out. Every time, it's the same thing - I get the cookie usage page..

I don't know why it isn't working..

If anyone is willing to try it out, I'll put the settings back for the cookies again right now..

Just go to.

Http://www.bptparts.com.

And try to add a part to a cart. Lemme know?..

Comment #4

Yep got this:.

Http://www.bptparts....ookie_usage.php.

This post has been edited by.

Yesudo.com.

: 09 March 2004, 19:25..

Comment #5

Yes, I receive the cookie useage screen as well. It must have been a contribution you've added or an alteration you've made...

Comment #6

I can't think of what. Oh! Okay, I added the contribution that changes the top tags of the page on product_info.php to include the part name and whatnot in the keywords and the title..

Could that be it? Please tell me yes. Heheh. I'm trying to think of what others I've added that would mess with that......

Comment #7

Nope. It wasn't product_info.php. I tried putting the pkg version in there and still the same problem...

Comment #8

Okay, how about this:.

Local Master.

Session.auto_start Off Off.

Session.bug_compat_42 On On.

Session.bug_compat_warn On On.

Session.cache_expire 180 180.

Session.cache_limiter nocache nocache.

Session.cookie_domain no value no value.

Session.cookie_lifetime 0 0.

Session.cookie_path /admin/ /.

That's what phpinfo tells me. Any problems there??..

Comment #9

I got it..

It was the cookie domain, I think. I think that the https has to be set as well, and both can't have http:// in them. Just so ya'll can see now, it is:.

Define('HTTP_SERVER', 'http://www.bptparts.com');.

Define('HTTPS_SERVER', 'https://www.bptparts.com');.

Define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

Define('HTTP_COOKIE_DOMAIN', 'www.bptparts.com');.

Define('HTTPS_COOKIE_DOMAIN', 'www.bptparts.com');.

Define('HTTP_COOKIE_PATH', '/');.

Define('HTTPS_COOKIE_PATH', '/');..

Comment #10

Howdy all,.

Well Ive searched and searched and still can't find any post to my exact problem..

This post seems closest to my problem, which is:.

When I first load my iPage site and then click on any link it just reloads the homepage. In the URL at the top of my browser it starts to load the cPath but then just puts in the session id instead. It's like the session id needs to be there before I can go anywhere. I can then surf my iPage site as normal, but there is always a oscsid in the url of everypage..

The iPage site functions perfectly other than that, but may confuse customers when they get to the iPage site and initially click on a link. The items in the infoBoxes also reload when I first click on a link..

I've tried forcing cookies and this worked, but then I could not add any items to the shopping cart..

This is all very weird and upsetting seeing as I can't figure out what's up..

I have many contributions installed and think that one of them may be the cuplret. Not sure though..

Thanks for any help or advice...

Comment #11

Okay, I've searched through this whole system for a solution. I've tried them all it seems. None have done it..

I want to use cookies. I don't want these long session ID's in my URL because engines are not indexing ANY of my other pages. But I keep getting the cookie_usage.php when I try to add anything to my cart. So does everyone else..

The three settings that pertain to this - what do I set them to?.

Prevent Spider Sessions - True?.

Force Cookies - True?.

Safe Url - True?.

I don't know. Also, I've messed around with my configure.php in my includes directory. Here are the settings I have right now:.

Define('HTTP_SERVER', 'http://www.bptparts.com');.

Define('HTTP_CATALOG_SERVER', 'http://www.bptparts.com');.

Define('HTTPS_CATALOG_SERVER', '');.

Define('HTTP_COOKIE_DOMAIN', 'www.bptparts.com');.

Define('HTTPS_COOKIE_DOMAIN', '');.

Define('HTTP_COOKIE_PATH', '/');.

Define('HTTPS_COOKIE_PATH', '/');.

Do I set the cookie path to /public_html/ or /www/? Do I set the iPage domain to www.bptparts.com or bptparts.com? Does any of this really affect what I'm trying to do?.

I KNOW that there is a way to do this, I've seen some osCommerce sites doing it effectively. I would really appreciate seeing a final answer to this problem if ANYONE has one. It seems like everyone is asking this same question again and again...

Comment #12

I know somebody out there has the solution to this. I've seen sites out there. Anyone???..

Comment #13


This question was taken from a support group/message board and re-posted here so others can learn from it.