chrometweaks.org

Why do I keep getting a iPage screen?

Click Here To View All Answers...


First of all Why do I keep getting a iPage screen? Thanks in advance for any response. Another question... Hi all.

I just uploaded osCommerce to an online site, and before that I had it on my own personal server. One is unix-based, the other is Windows. Both places, I've had the same problem..

When registering a new customer account, I input all the information and submit it, and it acts as though I never entered a state, which I know I entered each time I tried this..

The first time filling out the form, there is only a text box to fill in the state. But on the re-do, it gives me a dropbox to choose the state from..

How can this be fixed, so that registration can be completed on the first try?.

Thanks in advance..

Comments (78)

That's a good question. I'm not sure what is the right answer to your question. I'll do some research in Google and get back to you if I discover an answer. You should email the people at iPage as they probably can help you..

Comment #1

Thank you, Matt. I thought I had tried typing out the whole state, but I just tried again and was successful the first time. I don't want to make customers have to type in the whole state, though, so I'll try looking for the dropdown script you mentioned. Because of this glitch in the original code, I'm glad he's only shipping to the US, and I think the script would also help make sure that no one outside the US places an order..

I suppose I could always try and figure out a reverse of the script to have the US show up by default, instead of having a drop box full of countries to choose from as well. I think you helped me out with more than I originally thought I needed, lol. Thanks again!..

Comment #2

I was concerned about this as I'm not using the state dropdown list for my iPage site that services USA, Canada and international locations. So I decided to test the theory..

I created three new accounts as follows:.

1. Entered state as "Wash".

Result: In 'address book,' the state appears as "WA". When I click on the 'edit' button, it shows the full state name of "Washington.".

2. Entered state as "WA".

Result: In 'address book,' the state appears as "WA". When I click on the 'edit' button, it shows the full state name of "Washington.".

2. Entered state as "washington".

Result: In 'address book,' the state appears as "WA". When I click on the 'edit' button, it shows the full state name of "Washington.".

Could it be you're running a different version that doesn't have this flexibility? Or am I just incredibly lucky in my tests? I really want to be sure that I leave as little room for error as I can with this whole account process, while still accommodating my international customers..

Comments?.

TIA,.

Terry..

Comment #3

Taking this further, I'm testing Canadian provinces today..

1. Entered province as "Alta" (old abbreviation).

Result: Generated error message; with prompt to select from dropdown list..

2. Entered province as "AB".

Result: In 'address book,' the province appears as "AB". When I click on the 'edit' button, it shows the full province name of "Alberta.".

3. Entered province as "alberta".

Result: In 'address book,' the province appears as "AB". When I click on the 'edit' button, it shows the full province name of "Alberta.".

Terry..

Comment #4

I believe I'm running v2.2..

Edit to add: I just checked out your store, Terry, and love the customization you've done on it!.

This post has been edited by.

Lesa.

: 19 February 2004, 23:02..

Comment #5

In my searches this is as close to a solution that I can find..

I have a client who is having a problem:.

Her mother tried to input and order and this is the info she gave me in an email:.

My Mom has found a minor problem with the store! She tried to order an item and it all went through fine, except when she created her account in the "Create Account" page, it would not let her input "Surrey" as her County/State (as this is where she lives). So she clicked "Continue" and she got a message to say to select the County/State from the drop-down list and she could only choose "West Drayton" - which is where Mark and I live!!!.

This needs to be a free-format text box like the other address fields - can you make a minor tweak to remove whatever is defaulting to West Drayton to allow people to input plain text instead?!.

I have no idea how to fix this for her.....any suggestions would be very helpful. Her store is running on an older version of osComm. Before the MS2.2..

Thanks,.

Karole..

Comment #6

Upgrading will be very difficult as the db is not compatible. If anyone knows of an easy way to do that, let me know..

Karole..

Comment #7

Hi all.

I just uploaded osCommerce to an online site, and before that I had it on my own personal server. One is unix-based, the other is Windows. Both places, I've had the same problem..

When registering a new customer account, I input all the information and submit it, and it acts as though I never entered a state, which I know I entered each time I tried this..

The first time filling out the form, there is only a text box to fill in the state. But on the re-do, it gives me a dropbox to choose the state from..

How can this be fixed, so that registration can be completed on the first try?.

Thanks in advance..

Comment #8

You have to fill out the full name of the state rather than the two letter version (i.e. California, not CA). There are also posts in the forums to make it show a drop down by default (useful if you only ship to the US or some other single country)..

Hth,.

Matt..

Comment #9


This question was taken from a support group/message board and re-posted here so others can learn from it.