chrometweaks.org

Why won't my subdomains work on iPage.com?

Click Here To View All Answers...


Question I have... Why won't my subdomains work on iPage.com? Looking forward for any response. Another quick question... Greetings:.

I can see how to upload the thumbnail images for each product, and these are correctly displayed..

When I look at a product, I see the image in a box which says "Click to enlarge".

But when I click, I see the same small image open in a new broswer window..

How do I upload both a large image and a thumbnail???.

TIA.

Paul..

Comments (128)

Hmm... I need to find out myself. I don't know what is the right answer. I'll do some research and get back to you if I bump into an good answer. You should email the people at iPage as they probably could help you..

Comment #1

Thanks Melinda..

I figured that was how most people were handling it, but I'm sure I've seen sites that have separate images for the large and the thumbnail..

I'll see if I can find one. Maybe it was done with some heavy customization..

Paul..

Comment #2

Yep, here's one....

Sample.

If you click on the first image called "Teil Drops" the thumbnail image is called bubbles_b100x110.jpg and is 100x110px. But if you click the image to enlarge it, the enlarged image is called bubbles_b400.jpg and is 400x399px..

How did they do that?.

Paul..

Comment #3

Hmmm...mine aint doing right so far....

When I right click and save the large and small...they are the same size..

How exactly did you introduce the image to your store originally...

Maybe my problem is my method.

Ive tried ep and admin both ways the thumb and the enlarged are the same size...granted... it will give the dimensions, but the thumb is generated from the large...therefor so far on mine, it's the same size file...you know....

But on yours...yes...you're rollin! hooha!.

Thanks..

Comment #4

Paul, the different image names you are seeing is done automatically by osc using GD..

When you upload your full size image, as Melinda said, osc automatically creates the thumbnail. It also automatically renames it to include the dimensions based on your settings in the filename..

If you have an image imagename.jpg osc creates the thumbnail using GD, and saves it as tn_imagename_80x80.jpg (or whatever size you have set for your thumbs)..

Davinci;.

You upload it from the add product screen when you add a new product..

It sounds to me like you do not have GD enabled through your iPage hosting provider..

For GD to work, it has to be enabled on your hosts server for your site. If it is not, then the images are handled as you are experiencing, the thumbnail is just a smaller version of the large image, with the same file size. Only GD can actually create a seperate, true thumbnail image...

Comment #5

Im sure you're right, I see no reference to GD (not sure what stands for) on my host server info....

Im using cpanelx, even in there..no enabling or ref avail....

So...is it possible to get around this? make a true thumb href a large.jpg..

Comment #6

If you have GD you would see something like this under admin>tools>server info:.

Otherwise the contribution Automatic Thiumbnail Images v 1.0 or similar will not work. You should then use something like Photshop to resize images off-line and use a different contribuition..

This post has been edited by.

Radders.

: 31 January 2004, 14:16..

Comment #7

If you want, use this contrib to automaticly create thumbnails for you. all you have to do is upload the large image.

Http://www.oscommerc...tributions,1484..

Comment #8

Now i'm confused - if osC automatically creates the thumbnails for you so what is the purpose of the automatic thumbnails creator contrib. ?

Comment #9

And by the way you can upload different images for thumbs and normal if you install ultraPics or MoPics contributions...

Comment #10

Hi,.

Basically my cheat to this is to do the following :.

First I seperate images in 2 folders i.e. Large images and Small thumbnails but the main thing to be kept in mind is that names of both large and small images should be exacly same , now that you have seperated the images as large and small upload the images in catalog/images/small and catalog/images/large respectively , next open up catalog/includes/configure.php.

Find:.

Define('DIR_WS_IMAGES', 'images/');.

And change it to :.

Define('DIR_WS_IMAGES', 'images/small');.

Next add the folowing line under it:.

Define('DIR_WS_IMAGES_ZOOM', 'images/large');.

Now you have defined the 2 new paths for small and large images.

Next open catalog/popup_image.php.

Find:.

<?php echo tep_image(DIR_WS_IMAGES$products['products_image'], $products['products_name']); ?>.

And replace it with:.

<?php echo tep_image(DIR_WS_IMAGES_ZOOM$products['products_image'], $products['products_name']); ?>.

This should work out fine...now you have seperate thumbnail images and the popup shows the large images.....

Hope this works out for you...it did for me ...bye..

Comment #11

Thanks Again Noobish...I have referenced the above post 3 times now....

You'd think Id save it to my hd, but noooo! Open from location...just swell!.

ILL BE BACK!..

Comment #12

Greetings:.

I can see how to upload the thumbnail images for each product, and these are correctly displayed..

When I look at a product, I see the image in a box which says "Click to enlarge".

But when I click, I see the same small image open in a new broswer window..

How do I upload both a large image and a thumbnail???.

TIA.

Paul..

Comment #13

Hi,.

Upload the large image and oscommerce shrinks the image to whatever settings you have in configuration/images..

I normally remove all the image width settings (leave box blank) and just go by height so the image is constrained normally...

Comment #14


This question was taken from a support group/message board and re-posted here so others can learn from it.